summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-04-18 16:26:47 +0000
committerChristoph Mende <angelos@gentoo.org>2011-04-18 16:26:47 +0000
commita99ccd0758ded4ff73249a3eecfd35b6b6dc3884 (patch)
tree23a17868b4058c9f917f142b66be2a18bab2c989 /xfce-extra/xfce4-hdaps
parentVersion bump (diff)
downloadgentoo-2-a99ccd0758ded4ff73249a3eecfd35b6b6dc3884.tar.gz
gentoo-2-a99ccd0758ded4ff73249a3eecfd35b6b6dc3884.tar.bz2
gentoo-2-a99ccd0758ded4ff73249a3eecfd35b6b6dc3884.zip
Version bump
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-hdaps')
-rw-r--r--xfce-extra/xfce4-hdaps/ChangeLog9
-rw-r--r--xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.7.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-hdaps/ChangeLog b/xfce-extra/xfce4-hdaps/ChangeLog
index b78f7968c7f5..a5ab655779aa 100644
--- a/xfce-extra/xfce4-hdaps/ChangeLog
+++ b/xfce-extra/xfce4-hdaps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/xfce4-hdaps
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/ChangeLog,v 1.2 2010/03/25 19:59:46 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/ChangeLog,v 1.3 2011/04/18 16:26:47 angelos Exp $
+
+*xfce4-hdaps-0.0.7 (18 Apr 2011)
+
+ 18 Apr 2011; Christoph Mende <angelos@gentoo.org> +xfce4-hdaps-0.0.7.ebuild:
+ Version bump
*xfce4-hdaps-0.0.6 (25 Mar 2010)
diff --git a/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.7.ebuild b/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.7.ebuild
new file mode 100644
index 000000000000..d830dac150ec
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.7.ebuild,v 1.1 2011/04/18 16:26:47 angelos Exp $
+
+EAPI=4
+inherit linux-info xfconf
+
+DESCRIPTION="A plugin to indicate the status of the IBM Hard Drive Active Protection System"
+HOMEPAGE="http://michael.orlitzky.com/code/xfce4-hdaps.php"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.12:2
+ >=xfce-base/libxfce4ui-4.7
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/xfce4-panel-4.6"
+RDEPEND="${COMMON_DEPEND}
+ >=app-laptop/hdapsd-20081213
+ >=app-laptop/tp_smapi-0.39"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-option-checking
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 28; then
+ echo
+ ewarn "Unsupported kernel detected. Upgrade to 2.6.28 or above."
+ echo
+ fi
+}