summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-08-20 11:47:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-08-20 11:47:18 +0000
commit0829bc81fdeaca66835c5e39db3f2c845c4e06c6 (patch)
treef5ca6ed67262e7f8b330e29e2559d2fd21663313 /xfce-extra
parentInitial commit. (diff)
downloadgentoo-2-0829bc81fdeaca66835c5e39db3f2c845c4e06c6.tar.gz
gentoo-2-0829bc81fdeaca66835c5e39db3f2c845c4e06c6.tar.bz2
gentoo-2-0829bc81fdeaca66835c5e39db3f2c845c4e06c6.zip
Version bump (with, unfortunately, pulseaudio being a hardcoded dependency)
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.7.0.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-soundmenu-plugin/ChangeLog b/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
index 1ef52ee44b96..7da5b51a0e86 100644
--- a/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
+++ b/xfce-extra/xfce4-soundmenu-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-soundmenu-plugin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/ChangeLog,v 1.24 2014/04/11 14:57:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/ChangeLog,v 1.25 2014/08/20 11:47:18 ssuominen Exp $
+
+*xfce4-soundmenu-plugin-0.7.0 (20 Aug 2014)
+
+ 20 Aug 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-soundmenu-plugin-0.7.0.ebuild:
+ Version bump (with, unfortunately, pulseaudio being a hardcoded dependency)
11 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> metadata.xml,
xfce4-soundmenu-plugin-0.6.0.ebuild:
diff --git a/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.7.0.ebuild b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.7.0.ebuild
new file mode 100644
index 000000000000..1f487c0dd5d0
--- /dev/null
+++ b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.7.0.ebuild,v 1.1 2014/08/20 11:47:18 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A panel plug-in to control MPRIS2 compatible players like Pragha (from the same authors)"
+HOMEPAGE="http://github.com/matiasdelellis/xfce4-soundmenu-plugin"
+SRC_URI="http://github.com/matiasdelellis/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +glyr lastfm +keybinder"
+
+RDEPEND=">=dev-libs/glib-2.28
+ >=media-libs/libmpris2client-0.1
+ >=media-sound/pulseaudio-2[glib]
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ glyr? ( >=media-libs/glyr-1.0.0 )
+ lastfm? ( >=media-libs/libclastfm-0.5 )
+ keybinder? ( >=dev-libs/keybinder-0.2.2:0 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable keybinder)
+ $(use_enable lastfm libclastfm)
+ $(use_enable glyr libglyr)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}