summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-07-19 18:20:56 +0000
committerMichał Górny <mgorny@gentoo.org>2015-07-19 18:20:56 +0000
commita80c28febfb9cbc7bfc9a938a2869029c65d3061 (patch)
tree414a46794bd9bfffc39c59e4cf4d14f9628e2d22 /xfce-extra
parentia64 stable wrt bug #550152 (diff)
downloadgentoo-2-a80c28febfb9cbc7bfc9a938a2869029c65d3061.tar.gz
gentoo-2-a80c28febfb9cbc7bfc9a938a2869029c65d3061.tar.bz2
gentoo-2-a80c28febfb9cbc7bfc9a938a2869029c65d3061.zip
Add subslot operators to deps. Fix underlinking, bug #555056.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-radio-plugin/ChangeLog11
-rw-r--r--xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1-r1.ebuild33
2 files changed, 41 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-radio-plugin/ChangeLog b/xfce-extra/xfce4-radio-plugin/ChangeLog
index 308fec298c19..99bc2977b6a3 100644
--- a/xfce-extra/xfce4-radio-plugin/ChangeLog
+++ b/xfce-extra/xfce4-radio-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-radio-plugin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-radio-plugin/ChangeLog,v 1.21 2012/11/28 12:20:36 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-radio-plugin/ChangeLog,v 1.22 2015/07/19 18:20:56 mgorny Exp $
+
+*xfce4-radio-plugin-0.5.1-r1 (19 Jul 2015)
+
+ 19 Jul 2015; Michał Górny <mgorny@gentoo.org>
+ +xfce4-radio-plugin-0.5.1-r1.ebuild:
+ Add subslot operators to deps. Fix underlinking, bug #555056.
28 Nov 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-radio-plugin-0.5.1.ebuild:
@@ -98,4 +104,3 @@
23 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+xfce4-radio-plugin-0.3.1.ebuild, +xfce4-radio-plugin-0.4.2.ebuild:
Rename xfce4-radio to xfce4-radio-plugin.
-
diff --git a/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1-r1.ebuild b/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..ce24fe71edad
--- /dev/null
+++ b/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1-r1.ebuild,v 1.1 2015/07/19 18:20:56 mgorny Exp $
+
+EAPI=5
+inherit flag-o-matic multilib xfconf
+
+DESCRIPTION="V4L radio device control plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-radio-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfcegui4-4.8:=
+ >=xfce-base/xfce4-panel-4.8:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS NEWS README )
+
+ # fix underlinking, bug #555056
+ append-libs -lm
+}