summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/ario/ChangeLog10
-rw-r--r--media-sound/ario/ario-1.1.ebuild6
-rw-r--r--media-sound/ario/ario-1.2.ebuild61
-rw-r--r--media-sound/ario/metadata.xml1
4 files changed, 73 insertions, 5 deletions
diff --git a/media-sound/ario/ChangeLog b/media-sound/ario/ChangeLog
index d2877772bae1..233d6eed6a4e 100644
--- a/media-sound/ario/ChangeLog
+++ b/media-sound/ario/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/ario
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ChangeLog,v 1.7 2008/12/08 22:31:44 angelos Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ChangeLog,v 1.8 2009/01/03 00:17:29 angelos Exp $
+
+*ario-1.2 (03 Jan 2009)
+
+ 03 Jan 2009; Christoph Mende <angelos@gentoo.org> metadata.xml,
+ ario-1.1.ebuild, +ario-1.2.ebuild:
+ Version bump, bug 253502
08 Dec 2008; Christoph Mende <angelos@gentoo.org> ario-1.1.ebuild:
Added USE=audioscrobbler
diff --git a/media-sound/ario/ario-1.1.ebuild b/media-sound/ario/ario-1.1.ebuild
index 57925ec97a7c..91058393b252 100644
--- a/media-sound/ario/ario-1.1.ebuild
+++ b/media-sound/ario/ario-1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ario-1.1.ebuild,v 1.7 2008/12/08 22:31:44 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ario-1.1.ebuild,v 1.8 2009/01/03 00:17:29 angelos Exp $
EAPI=1
inherit autotools eutils gnome2-utils
@@ -9,7 +9,7 @@ DESCRIPTION="a GTK2 MPD (Music Player Daemon) client inspired by Rythmbox"
HOMEPAGE="http://ario-player.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}-player/${P}.tar.gz"
-LICENSE="GPL-1"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="audioscrobbler dbus debug zeroconf"
diff --git a/media-sound/ario/ario-1.2.ebuild b/media-sound/ario/ario-1.2.ebuild
new file mode 100644
index 000000000000..8b402f4da948
--- /dev/null
+++ b/media-sound/ario/ario-1.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ario-1.2.ebuild,v 1.1 2009/01/03 00:17:29 angelos Exp $
+
+EAPI=1
+inherit gnome2-utils
+
+DESCRIPTION="a GTK2 MPD (Music Player Daemon) client inspired by Rythmbox"
+HOMEPAGE="http://ario-player.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}-player/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="audioscrobbler dbus debug idle libnotify nls python zeroconf"
+
+RDEPEND=">=dev-libs/glib-2.14:2
+ gnome-base/libglade:2.0
+ net-misc/curl
+ net-libs/gnutls
+ >=x11-libs/gtk+-2.12:2
+ audioscrobbler? ( net-libs/libsoup:2.4 )
+ dbus? ( dev-libs/dbus-glib )
+ libnotify? ( x11-libs/libnotify )
+ python? ( dev-python/pygtk
+ dev-python/pygobject )
+ zeroconf? ( net-dns/avahi )"
+DEPEND="sys-devel/gettext
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ $(use_enable audioscrobbler) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable idle mpdidle) \
+ $(use_enable libnotify notify) \
+ $(use_enable nls) \
+ $(use_enable python) \
+ $(use_enable zeroconf avahi)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/media-sound/ario/metadata.xml b/media-sound/ario/metadata.xml
index 5fded9fdacab..eeecb3130056 100644
--- a/media-sound/ario/metadata.xml
+++ b/media-sound/ario/metadata.xml
@@ -8,5 +8,6 @@
</maintainer>
<use>
<flag name="audioscrobbler">Enable song tracking via last.fm</flag>
+ <flag name="idle">Enable experimental support for MPD's idle command to reduce bandwith and cpu usage, requires MPD 0.14</flag>
</use>
</pkgmetadata>