summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/aumix/ChangeLog11
-rw-r--r--media-sound/aumix/aumix-2.8-r5.ebuild60
-rw-r--r--media-sound/aumix/files/aumix-2.8-noninter_strncpy.patch26
-rw-r--r--media-sound/aumix/files/aumix.desktop7
4 files changed, 95 insertions, 9 deletions
diff --git a/media-sound/aumix/ChangeLog b/media-sound/aumix/ChangeLog
index d24cd4fa1b36..592627831ab4 100644
--- a/media-sound/aumix/ChangeLog
+++ b/media-sound/aumix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/aumix
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/ChangeLog,v 1.65 2008/03/31 04:10:09 ricmm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/ChangeLog,v 1.66 2009/05/12 11:43:57 ssuominen Exp $
+
+*aumix-2.8-r5 (12 May 2009)
+
+ 12 May 2009; Samuli Suominen <ssuominen@gentoo.org> +aumix-2.8-r5.ebuild,
+ +files/aumix-2.8-noninter_strncpy.patch:
+ Fix buffer overflow when changing volume wrt #260985, thanks to Guillaume
+ Rosaire and Magnus Granberg.
31 Mar 2008; <ricmm@gentoo.org> aumix-2.8-r4.ebuild:
Drop to ~mips due to unstable deps
diff --git a/media-sound/aumix/aumix-2.8-r5.ebuild b/media-sound/aumix/aumix-2.8-r5.ebuild
new file mode 100644
index 000000000000..8960227ccc09
--- /dev/null
+++ b/media-sound/aumix/aumix-2.8-r5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/aumix-2.8-r5.ebuild,v 1.1 2009/05/12 11:43:57 ssuominen Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Aumix volume/mixer control program"
+HOMEPAGE="http://jpj.net/~trevor/aumix.html"
+SRC_URI="http://jpj.net/~trevor/aumix/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="gpm gtk nls"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ gtk? ( >=x11-libs/gtk+-2:2 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ sys-apps/findutils
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nohome.patch \
+ "${FILESDIR}"/${P}-close-dialogs.patch \
+ "${FILESDIR}"/${P}-save_load.patch \
+ "${FILESDIR}"/${P}-nls.patch \
+ "${FILESDIR}"/${P}-mute.patch \
+ "${FILESDIR}"/${P}-noninter_strncpy.patch
+
+ # Prevent autotools from rerunning, bug #70379.
+ touch aclocal.m4 configure
+ find . -name Makefile.in -o -name stamp-h.in -print0 | xargs -0 touch;
+ touch configure
+}
+
+src_configure() {
+ local myconf="--without-gtk1"
+
+ use gtk || myconf="${myconf} --without-gtk"
+ use gpm || myconf="${myconf} --without-gpm"
+
+ econf \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+
+ newinitd "${FILESDIR}"/aumix.rc6 aumix
+
+ if use gtk; then
+ doicon data/aumix.xpm
+ make_desktop_entry aumix Aumix aumix
+ fi
+}
diff --git a/media-sound/aumix/files/aumix-2.8-noninter_strncpy.patch b/media-sound/aumix/files/aumix-2.8-noninter_strncpy.patch
new file mode 100644
index 000000000000..2c68873c29ae
--- /dev/null
+++ b/media-sound/aumix/files/aumix-2.8-noninter_strncpy.patch
@@ -0,0 +1,26 @@
+diff -ur aumix-2.8.orig/src/common.c aumix-2.8/src/common.c
+--- aumix-2.8.orig/src/common.c 2002-10-29 23:27:51.000000000 +0200
++++ aumix-2.8/src/common.c 2009-05-12 14:36:08.000000000 +0300
+@@ -612,17 +612,18 @@
+ int SetShowNoninter(int dev)
+ {
+ /* Change or display settings from the command line. */
+- char *devstr, dest;
++ char *devstr;
++ char dest[4];
+ int change = 0, tmp, left, right;
+ /* Increase or decrease levels, optionally by a number. */
+ if (!strncmp(optarg, "+", 1) || !strncmp(optarg, "-", 1)) {
+ ErrorExitWarn(ReadLevel(dev, &tmp), 'e');
+ right = tmp >> 8; /* I'll take the high byte, */
+ left = tmp & 0xFF; /* and you take the low byte. */
+- strncpy(&dest, (optarg + 1), 3);
++ strncpy(dest, (optarg + 1), 3);
+ change = 1; /* For compatibility with versions 1.15 to 1.17, assume one if no number was given. */
+- if (atoi(&dest))
+- change = atoi(&dest);
++ if (atoi(dest))
++ change = atoi(dest);
+ if (*optarg == '+') { /* increase */
+ right += change;
+ left += change;
diff --git a/media-sound/aumix/files/aumix.desktop b/media-sound/aumix/files/aumix.desktop
deleted file mode 100644
index 0bf998c5ffea..000000000000
--- a/media-sound/aumix/files/aumix.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Name=Aumix
-Comment=Aumix volume/mixer control program
-Exec=aumix
-Icon=aumix.xpm
-Terminal=0
-Type=Application