summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/fabric/ChangeLog8
-rw-r--r--dev-python/fabric/fabric-1.4.2.ebuild57
-rw-r--r--dev-python/fabric/files/fabric-1.4.2-git_tags_docs.patch21
3 files changed, 85 insertions, 1 deletions
diff --git a/dev-python/fabric/ChangeLog b/dev-python/fabric/ChangeLog
index 9bf968aba375..2f77d8d74195 100644
--- a/dev-python/fabric/ChangeLog
+++ b/dev-python/fabric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/fabric
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/ChangeLog,v 1.21 2012/04/08 19:19:05 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/ChangeLog,v 1.22 2012/05/10 23:31:35 neurogeek Exp $
+
+*fabric-1.4.2 (10 May 2012)
+
+ 10 May 2012; Jesus Rivero <neurogeek@gentoo.org> +fabric-1.4.2.ebuild,
+ +files/fabric-1.4.2-git_tags_docs.patch:
+ Version bump.
*fabric-1.4.1 (08 Apr 2012)
diff --git a/dev-python/fabric/fabric-1.4.2.ebuild b/dev-python/fabric/fabric-1.4.2.ebuild
new file mode 100644
index 000000000000..104655d4c597
--- /dev/null
+++ b/dev-python/fabric/fabric-1.4.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/fabric-1.4.2.ebuild,v 1.1 2012/05/10 23:31:35 neurogeek Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.* *-jython"
+#DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils eutils
+
+MY_PN="Fabric"
+MY_P="${MY_PN}-${PV}"
+GIT_HASH_TAG="3a4006e"
+
+DESCRIPTION="Fabric is a simple, Pythonic tool for remote execution and deployment."
+HOMEPAGE="http://fabfile.org http://pypi.python.org/pypi/Fabric"
+SRC_URI="http://github.com/${PN}/${PN}/tarball/${PV} -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-python/ssh-1.7.14"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+# test? ( dev-python/fudge )"
+
+# Tests broken.
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}-${PN}-${GIT_HASH_TAG}"
+
+PYTHON_MODULES="fabfile fabric"
+
+src_prepare() {
+ use doc &&
+ epatch "${FILESDIR}"/${P}-git_tags_docs.patch
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ emake -C docs html || die "Couldn't make docs"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/_build/html
+ fi
+}
diff --git a/dev-python/fabric/files/fabric-1.4.2-git_tags_docs.patch b/dev-python/fabric/files/fabric-1.4.2-git_tags_docs.patch
new file mode 100644
index 000000000000..46e9044a45c6
--- /dev/null
+++ b/dev-python/fabric/files/fabric-1.4.2-git_tags_docs.patch
@@ -0,0 +1,21 @@
+--- docs/conf.py.org 2012-05-08 02:08:14.000000000 -0400
++++ docs/conf.py 2012-05-10 10:06:28.000000000 -0400
+@@ -170,12 +170,13 @@
+ html_theme = 'default'
+ html_style = 'rtd.css'
+
+-from fabric.api import local, hide
+-with hide('everything'):
+- get_tags = 'git tag | sort -r | egrep "(1\.[^0]+)\.."'
+- fabric_tags = local(get_tags, True).split()
+-html_context = {'fabric_tags': fabric_tags}
++#from fabric.api import local, hide
++#with hide('everything'):
++# get_tags = 'git tag | sort -r | egrep "(1\.[^0]+)\.."'
++# fabric_tags = local(get_tags, True).split()
++#html_context = {'fabric_tags': fabric_tags}
+
++html_context={'fabric_tags': ['1.4.2', '1.4.1', '1.4.0', '1.3.7', '1.3.6', '1.3.5', '1.3.4', '1.3.3', '1.3.2', '1.3.1', '1.3.0', '1.2.6', '1.2.5', '1.2.4', '1.2.3', '1.2.2', '1.2.1', '1.2.0', '1.1.8', '1.1.7', '1.1.6', '1.1.5', '1.1.4', '1.1.3', '1.1.2', '1.1.1', '1.1.0']}
+
+ # Theme options are theme-specific and customize the look and feel of a theme
+ # further. For a list of options available for each theme, see the