summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/flphoto/ChangeLog8
-rw-r--r--media-gfx/flphoto/flphoto-1.2.ebuild8
-rw-r--r--media-gfx/flphoto/flphoto-1.3.1.ebuild10
3 files changed, 17 insertions, 9 deletions
diff --git a/media-gfx/flphoto/ChangeLog b/media-gfx/flphoto/ChangeLog
index 4291abc0aad1..4dd37e69dd7b 100644
--- a/media-gfx/flphoto/ChangeLog
+++ b/media-gfx/flphoto/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for media-gfx/flphoto
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/ChangeLog,v 1.11 2007/09/20 14:05:05 armin76 Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/ChangeLog,v 1.12 2008/11/14 18:54:20 coldwind Exp $
26 Jul 2003; Jared Hudson <jhhudso@gentoo.org> : Fixed flphoto so that it only
depends on a specific version of fltk, since the other versions cause
compile errors.
+ 14 Nov 2008; Santiago M. Mola <coldwind@gentoo.org> flphoto-1.2.ebuild,
+ flphoto-1.3.1.ebuild:
+ Restrict fltk dependency to SLOT 1.1 (bug #246445).
+
*flphoto-1.3.1 (20 Sep 2007)
20 Sep 2007; Raúl Porcel <armin76@gentoo.org> -flphoto-1.1.ebuild,
diff --git a/media-gfx/flphoto/flphoto-1.2.ebuild b/media-gfx/flphoto/flphoto-1.2.ebuild
index 36005b5dc530..fd3a8549da74 100644
--- a/media-gfx/flphoto/flphoto-1.2.ebuild
+++ b/media-gfx/flphoto/flphoto-1.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.2.ebuild,v 1.6 2007/09/20 14:05:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.2.ebuild,v 1.7 2008/11/14 18:54:20 coldwind Exp $
+
+EAPI=1
DESCRIPTION="Basic image management and display program based on the FLTK toolkit"
HOMEPAGE="http://www.easysw.com/~mike/flphoto/"
@@ -11,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
IUSE="cups gphoto2"
-DEPEND=">=x11-libs/fltk-1.1.4
+DEPEND=">=x11-libs/fltk-1.1.4:1.1
cups? ( net-print/cups )
gphoto2? ( media-gfx/gphoto2 )"
diff --git a/media-gfx/flphoto/flphoto-1.3.1.ebuild b/media-gfx/flphoto/flphoto-1.3.1.ebuild
index 3e3ea91f319a..bf9c84bb4590 100644
--- a/media-gfx/flphoto/flphoto-1.3.1.ebuild
+++ b/media-gfx/flphoto/flphoto-1.3.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.3.1.ebuild,v 1.1 2007/09/20 14:05:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/flphoto/flphoto-1.3.1.ebuild,v 1.2 2008/11/14 18:54:20 coldwind Exp $
+
+EAPI=1
DESCRIPTION="Basic image management and display program based on the FLTK toolkit"
HOMEPAGE="http://www.easysw.com/~mike/flphoto/"
@@ -11,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="cups gphoto2"
-DEPEND=">=x11-libs/fltk-1.1.4
+DEPEND=">=x11-libs/fltk-1.1.4:1.1
cups? ( net-print/cups )
gphoto2? ( media-gfx/gphoto2 )"
@@ -21,5 +23,5 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
}