summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/memtest86/ChangeLog8
-rw-r--r--sys-apps/memtest86/files/memtest86-3.5-build.patch5
-rw-r--r--sys-apps/memtest86/files/memtest86-4.0-build.patch41
-rw-r--r--sys-apps/memtest86/memtest86-4.0.ebuild53
4 files changed, 103 insertions, 4 deletions
diff --git a/sys-apps/memtest86/ChangeLog b/sys-apps/memtest86/ChangeLog
index bcd263f0b120..3a0df371a631 100644
--- a/sys-apps/memtest86/ChangeLog
+++ b/sys-apps/memtest86/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/memtest86
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.38 2011/01/09 03:24:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.39 2011/06/15 04:55:11 jer Exp $
+
+*memtest86-4.0 (15 Jun 2011)
+
+ 15 Jun 2011; Jeroen Roovers <jer@gentoo.org> files/memtest86-3.5-build.patch,
+ +memtest86-4.0.ebuild, +files/memtest86-4.0-build.patch:
+ Version bump.
09 Jan 2011; Mike Frysinger <vapier@gentoo.org> memtest86-3.3.ebuild,
memtest86-3.4.ebuild, memtest86-3.5.ebuild:
diff --git a/sys-apps/memtest86/files/memtest86-3.5-build.patch b/sys-apps/memtest86/files/memtest86-3.5-build.patch
index 6c47cddb180d..04f45bffa5eb 100644
--- a/sys-apps/memtest86/files/memtest86-3.5-build.patch
+++ b/sys-apps/memtest86/files/memtest86-3.5-build.patch
@@ -1,8 +1,7 @@
make sure all the flags in question force i386 and disable SSP
-diff -Nuar --exclude '*.orig' memtest86-3.5.orig//Makefile memtest86-3.5//Makefile
---- memtest86-3.5.orig//Makefile 2010-03-31 19:43:35.355817421 +0000
-+++ memtest86-3.5//Makefile 2010-03-31 19:47:10.922462467 +0000
+--- a/Makefile
++++ b/Makefile
@@ -8,10 +8,9 @@
#
FDISK=/dev/fd0
diff --git a/sys-apps/memtest86/files/memtest86-4.0-build.patch b/sys-apps/memtest86/files/memtest86-4.0-build.patch
new file mode 100644
index 000000000000..6e2fe6a4d428
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-4.0-build.patch
@@ -0,0 +1,41 @@
+--- Makefile.org 2011-03-30 16:58:52.000000000 +0200
++++ Makefile 2011-06-15 06:52:44.000000000 +0200
+@@ -8,11 +8,9 @@
+ #
+ FDISK=/dev/fd0
+
+-AS=as -32
+-CC=gcc
++ASFLAGS=-32
+
+-CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin \
+- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
++CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector $(SMP_FL)
+
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o linuxbios.o memsize.o error.o smp.o cpuid.o vmem.o random.o
+@@ -23,7 +21,7 @@
+ # symbols and then link it dynamically so I have full
+ # relocation information
+ memtest_shared: $(OBJS) memtest_shared.lds Makefile
+- $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds \
++ $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds -m elf_i386 \
+ -o $@ $(OBJS) && \
+ $(LD) -shared -Bsymbolic -T memtest_shared.lds -o $@ $(OBJS)
+
+@@ -50,7 +48,7 @@
+ $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
+
+ test.o: test.c
+- $(CC) -c -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin -ffreestanding test.c
++ $(CC) -c $(CFLAGS:-fPIC=) -o $@ $<
+
+ random.o: random.c
+ $(CC) -c -Wall -march=i486 -m32 -O3 -fomit-frame-pointer -fno-builtin -ffreestanding random.c
+@@ -72,3 +70,6 @@
+ dos: all
+ cat mt86+_loader memtest.bin > memtest.exe
+
++head.o: head.s
++bootsect.o: bootsect.s
++setup.o: setup.s
diff --git a/sys-apps/memtest86/memtest86-4.0.ebuild b/sys-apps/memtest86/memtest86-4.0.ebuild
new file mode 100644
index 000000000000..bb54475a9a03
--- /dev/null
+++ b/sys-apps/memtest86/memtest86-4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-4.0.ebuild,v 1.1 2011/06/15 04:55:11 jer Exp $
+
+inherit mount-boot eutils toolchain-funcs
+
+DESCRIPTION="A stand alone memory test for x86 computers"
+HOMEPAGE="http://www.memtest86.com/"
+SRC_URI="http://www.memtest86.com/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="serial"
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.0-build.patch #66630
+
+ if use serial ; then
+ sed -i \
+ -e '/^#define SERIAL_CONSOLE_DEFAULT/s:0:1:' \
+ config.h \
+ || die "sed failed"
+ fi
+
+ tc-export AS CC LD
+}
+
+src_install() {
+ insinto /boot/memtest86
+ doins memtest.bin || die "doins failed"
+ dodoc README README.build-process
+}
+
+pkg_postinst() {
+ mount-boot_pkg_postinst
+ einfo
+ einfo "memtest.bin has been installed in /boot/memtest86/"
+ einfo "You may wish to update your bootloader configs"
+ einfo "by adding these lines:"
+ einfo " - For grub: (replace '?' with correct numbers for your boot partition)"
+ einfo " > title=Memtest86"
+ einfo " > root (hd?,?)"
+ einfo " > kernel /boot/memtest86/memtest.bin"
+ einfo " - For lilo:"
+ einfo " > image = /boot/memtest86/memtest.bin"
+ einfo " > label = Memtest86"
+ einfo
+}