summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tcltk/thread/ChangeLog10
-rw-r--r--dev-tcltk/thread/thread-2.6.2.ebuild19
-rw-r--r--dev-tcltk/thread/thread-2.6.6.ebuild48
3 files changed, 66 insertions, 11 deletions
diff --git a/dev-tcltk/thread/ChangeLog b/dev-tcltk/thread/ChangeLog
index b229dc740954..76e590a0537b 100644
--- a/dev-tcltk/thread/ChangeLog
+++ b/dev-tcltk/thread/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/thread
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.16 2009/08/14 00:45:12 fauli Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/ChangeLog,v 1.17 2010/12/07 13:40:29 jlec Exp $
+
+*thread-2.6.6 (07 Dec 2010)
+
+ 07 Dec 2010; Justin Lecher <jlec@gentoo.org> thread-2.6.2.ebuild,
+ +thread-2.6.6.ebuild:
+ Version Bump, which fixes the LDFLAGS repect, #335963
14 Aug 2009; Christian Faulhammer <fauli@gentoo.org> thread-2.6.2.ebuild:
port to EAPI 2
diff --git a/dev-tcltk/thread/thread-2.6.2.ebuild b/dev-tcltk/thread/thread-2.6.2.ebuild
index 3307965d594b..5765584c26ad 100644
--- a/dev-tcltk/thread/thread-2.6.2.ebuild
+++ b/dev-tcltk/thread/thread-2.6.2.ebuild
@@ -1,25 +1,26 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.2.ebuild,v 1.15 2009/08/14 00:45:12 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.2.ebuild,v 1.16 2010/12/07 13:40:30 jlec Exp $
EAPI=2
inherit autotools eutils multilib
-DESCRIPTION="the Tcl Thread extension"
+DESCRIPTION="Tcl Thread extension"
HOMEPAGE="http://www.tcl.tk/"
SRC_URI="mirror://sourceforge/tcl/${PN}${PV}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="gdbm"
+IUSE="debug gdbm"
-DEPEND="gdbm? ( sys-libs/gdbm )
- dev-lang/tcl[threads]"
+DEPEND="
+ dev-lang/tcl[threads]
+ gdbm? ( sys-libs/gdbm )"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${PN}${PV}
+S="${WORKDIR}"/${PN}${PV}
RESTRICT="test"
@@ -41,10 +42,10 @@ src_configure() {
--with-threads \
--with-tclinclude=/usr/include \
--with-tcl="/usr/$(get_libdir)" \
- ${use_gdbm} || die "econf failed"
+ ${use_gdbm}
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
- dodoc ChangeLog README
+ dodoc ChangeLog README || die
}
diff --git a/dev-tcltk/thread/thread-2.6.6.ebuild b/dev-tcltk/thread/thread-2.6.6.ebuild
new file mode 100644
index 000000000000..38aac39f5daa
--- /dev/null
+++ b/dev-tcltk/thread/thread-2.6.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.6.ebuild,v 1.1 2010/12/07 13:40:28 jlec Exp $
+
+EAPI=2
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Tcl Thread extension"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gdbm"
+
+DEPEND="
+ dev-lang/tcl[threads]
+ gdbm? ( sys-libs/gdbm )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}${PV}
+
+RESTRICT="test"
+
+src_prepare() {
+ # Search for libs in libdir not just exec_prefix/lib
+ sed -i -e 's:${exec_prefix}/lib:${libdir}:' \
+ aclocal.m4 || die "sed failed"
+
+ sed -i -e "s/relid'/relid/" tclconfig/tcl.m4
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-tclinclude=/usr/include \
+ --with-tcl="/usr/$(get_libdir)" \
+ $(use_with gdbm) \
+ $(use_enable debug symbols)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README || die
+}