summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/kvirc/ChangeLog6
-rw-r--r--net-irc/kvirc/kvirc-4.2_pre6066.ebuild10
-rw-r--r--net-irc/kvirc/kvirc-9999.ebuild10
3 files changed, 15 insertions, 11 deletions
diff --git a/net-irc/kvirc/ChangeLog b/net-irc/kvirc/ChangeLog
index 9cf67e9cff38..3430254e4744 100644
--- a/net-irc/kvirc/ChangeLog
+++ b/net-irc/kvirc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/kvirc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/ChangeLog,v 1.146 2012/05/26 00:55:30 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/ChangeLog,v 1.147 2012/05/26 01:00:09 floppym Exp $
+
+ 26 May 2012; Mike Gilbert <floppym@gentoo.org> kvirc-4.2_pre6066.ebuild,
+ kvirc-9999.ebuild:
+ Sort USE flags. Patch by Arfrever.
26 May 2012; Mike Gilbert <floppym@gentoo.org> -kvirc-4.2_pre5816.ebuild:
Remove old version per Arfrever.
diff --git a/net-irc/kvirc/kvirc-4.2_pre6066.ebuild b/net-irc/kvirc/kvirc-4.2_pre6066.ebuild
index 7f2cf3e4af09..f4f0bd1f2c4c 100644
--- a/net-irc/kvirc/kvirc-4.2_pre6066.ebuild
+++ b/net-irc/kvirc/kvirc-4.2_pre6066.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-4.2_pre6066.ebuild,v 1.5 2012/05/25 23:11:54 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-4.2_pre6066.ebuild,v 1.6 2012/05/26 01:00:08 floppym Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
@@ -14,7 +14,7 @@ SRC_URI="http://people.apache.org/~Arfrever/gentoo/${P}.tar.xz"
LICENSE="kvirc"
SLOT="4"
KEYWORDS="~alpha amd64 ~ppc ~ppc64 x86"
-IUSE="audiofile dcc_video +dcc_voice debug doc gsm +ipc ipv6 kde +nls oss +perl +phonon profile +python +qt-dbus webkit +ssl theora +transparency"
+IUSE="audiofile dcc_video +dcc_voice debug doc gsm +ipc ipv6 kde +nls oss +perl +phonon profile +python +qt-dbus +ssl theora +transparency webkit"
RDEPEND="sys-libs/zlib
x11-libs/libX11
@@ -30,8 +30,8 @@ RDEPEND="sys-libs/zlib
perl? ( dev-lang/perl )
phonon? ( || ( media-libs/phonon >=x11-libs/qt-phonon-4.6 ) )
qt-dbus? ( >=x11-libs/qt-dbus-4.6 )
- webkit? ( >=x11-libs/qt-webkit-4.6 )
- ssl? ( dev-libs/openssl )"
+ ssl? ( dev-libs/openssl )
+ webkit? ( >=x11-libs/qt-webkit-4.6 )"
DEPEND="${RDEPEND}
>=dev-util/cmake-2.6.4
virtual/pkgconfig
@@ -84,10 +84,10 @@ src_configure() {
$(cmake-utils_use_want profile MEMORY_PROFILE)
$(cmake-utils_use_want python PYTHON)
$(cmake-utils_use_want qt-dbus QTDBUS)
- $(cmake-utils_use_want webkit QTWEBKIT)
$(cmake-utils_use_want ssl OPENSSL)
$(cmake-utils_use_want theora OGG_THEORA)
$(cmake-utils_use_want transparency TRANSPARENCY)
+ $(cmake-utils_use_want webkit QTWEBKIT)
)
cmake-utils_src_configure
diff --git a/net-irc/kvirc/kvirc-9999.ebuild b/net-irc/kvirc/kvirc-9999.ebuild
index 74de5dc2af43..ae03b2ccb869 100644
--- a/net-irc/kvirc/kvirc-9999.ebuild
+++ b/net-irc/kvirc/kvirc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-9999.ebuild,v 1.33 2012/05/25 23:11:54 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/kvirc/kvirc-9999.ebuild,v 1.34 2012/05/26 01:00:08 floppym Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
@@ -16,7 +16,7 @@ ESVN_PROJECT="kvirc"
LICENSE="kvirc"
SLOT="4"
KEYWORDS=""
-IUSE="audiofile dcc_video +dcc_voice debug doc gsm +ipc ipv6 kde +nls oss +perl +phonon profile +python +qt-dbus webkit +ssl theora +transparency"
+IUSE="audiofile dcc_video +dcc_voice debug doc gsm +ipc ipv6 kde +nls oss +perl +phonon profile +python +qt-dbus +ssl theora +transparency webkit"
RDEPEND="sys-libs/zlib
x11-libs/libX11
@@ -32,8 +32,8 @@ RDEPEND="sys-libs/zlib
perl? ( dev-lang/perl )
phonon? ( || ( media-libs/phonon >=x11-libs/qt-phonon-4.6 ) )
qt-dbus? ( >=x11-libs/qt-dbus-4.6 )
- webkit? ( >=x11-libs/qt-webkit-4.6 )
- ssl? ( dev-libs/openssl )"
+ ssl? ( dev-libs/openssl )
+ webkit? ( >=x11-libs/qt-webkit-4.6 )"
DEPEND="${RDEPEND}
>=dev-util/cmake-2.6.4
virtual/pkgconfig
@@ -87,10 +87,10 @@ src_configure() {
$(cmake-utils_use_want profile MEMORY_PROFILE)
$(cmake-utils_use_want python PYTHON)
$(cmake-utils_use_want qt-dbus QTDBUS)
- $(cmake-utils_use_want webkit QTWEBKIT)
$(cmake-utils_use_want ssl OPENSSL)
$(cmake-utils_use_want theora OGG_THEORA)
$(cmake-utils_use_want transparency TRANSPARENCY)
+ $(cmake-utils_use_want webkit QTWEBKIT)
)
cmake-utils_src_configure