summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/isodate/ChangeLog11
-rw-r--r--dev-python/isodate/isodate-0.4.7.ebuild32
-rw-r--r--dev-python/isodate/metadata.xml18
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/isodate/ChangeLog b/dev-python/isodate/ChangeLog
new file mode 100644
index 000000000000..b5587afb3101
--- /dev/null
+++ b/dev-python/isodate/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/isodate
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/isodate/ChangeLog,v 1.1 2012/05/04 08:53:09 xarthisius Exp $
+
+*isodate-0.4.7 (04 May 2012)
+
+ 04 May 2012; Kacper Kowalik <xarthisius@gentoo.org> +isodate-0.4.7.ebuild,
+ +metadata.xml:
+ Initial import, ebuild written by me. Fixes #408503 by Ian Delaney
+ <johneed@hotmail.com>
+
diff --git a/dev-python/isodate/isodate-0.4.7.ebuild b/dev-python/isodate/isodate-0.4.7.ebuild
new file mode 100644
index 000000000000..d07816027d2e
--- /dev/null
+++ b/dev-python/isodate/isodate-0.4.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/isodate/isodate-0.4.7.ebuild,v 1.1 2012/05/04 08:53:09 xarthisius Exp $
+
+EAPI=4
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST=setup.py
+RESTRICT_PYTHON_ABIS="2.7-pypy-*"
+
+inherit distutils
+
+DESCRIPTION="ISO 8601 date/time/duration parser and formater"
+HOMEPAGE="http://pypi.python.org/pypi/isodate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+DOCS="CHANGES.txt README.txt"
+
+src_prepare() {
+ # Skip test failing for python \not\in {2.7,3.2}
+ sed -e '/test_strf.test_suite/d' \
+ -i src/isodate/tests/__init__.py || die
+
+ distutils_src_prepare
+}
diff --git a/dev-python/isodate/metadata.xml b/dev-python/isodate/metadata.xml
new file mode 100644
index 000000000000..868a672962e5
--- /dev/null
+++ b/dev-python/isodate/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+ This module implements ISO 8601 date, time and duration
+ parsing. The implementation follows ISO8601:2004 standard, and
+ implements only date/time representations mentioned in the standard. If
+ something is not mentioned there, then it is treated as non existent,
+ and not as an allowed option.
+ As this module maps ISO 8601 dates/times to standard Python data types,
+ like date, time, datetime and timedelta, it is not possible to convert
+ all possible ISO 8601 dates/times. For instance, dates before 0001-01-01
+ are not allowed by the Python date and datetime classes. Additionally
+ fractional seconds are limited to microseconds. That means if the parser
+ finds for instance nanoseconds it will round it to microseconds.
+ </longdescription>
+</pkgmetadata>