summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/mutella/ChangeLog5
-rw-r--r--net-p2p/mutella/mutella-0.4.1.ebuild4
-rw-r--r--net-www/skipstone/skipstone-0.8.3.ebuild31
-rw-r--r--sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild26
4 files changed, 24 insertions, 42 deletions
diff --git a/net-p2p/mutella/ChangeLog b/net-p2p/mutella/ChangeLog
index 0fe017dd3e1d..4d485e8ba803 100644
--- a/net-p2p/mutella/ChangeLog
+++ b/net-p2p/mutella/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for net-p2p/mutella
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mutella/ChangeLog,v 1.6 2002/11/03 19:32:11 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mutella/ChangeLog,v 1.7 2002/12/05 15:44:20 vapier Exp $
*mutella-0.4.1 (03 Nov 2002)
@@ -11,7 +11,6 @@
03 Nov 2002; Matthew Kennedy <mkennedy@gentoo.org>
files/mutella-gcc3-gentoo.patch, ChangeLog, mutella-0.3.3.ebuild :
-
Fix for gcc3.2.
*mutella-0.4 (09 Jul 2002)
@@ -26,13 +25,11 @@
#4312.] Updated the old version to include a KEYWORD as well.
26 Jun 2002; Thilo Bangert <bangert@gentoo.org> :
-
moved to net-p2p
*mutella-0.3.3 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/net-p2p/mutella/mutella-0.4.1.ebuild b/net-p2p/mutella/mutella-0.4.1.ebuild
index 09a49d9113bf..f3aba1109f0e 100644
--- a/net-p2p/mutella/mutella-0.4.1.ebuild
+++ b/net-p2p/mutella/mutella-0.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/mutella/mutella-0.4.1.ebuild,v 1.2 2002/11/12 06:54:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/mutella/mutella-0.4.1.ebuild,v 1.3 2002/12/05 15:44:20 vapier Exp $
DESCRIPTION="Text-mode gnutella client"
SRC_URI="mirror://sourceforge/mutella/${P}.tar.gz"
@@ -11,7 +11,7 @@ LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc"
DEPEND="virtual/glibc
- >=sys-libs/readline-4.2"
+ sys-libs/readline"
src_compile() {
CXXFLAGS="${CXXFLAGS} -DNAVE_NO_SLIST "
diff --git a/net-www/skipstone/skipstone-0.8.3.ebuild b/net-www/skipstone/skipstone-0.8.3.ebuild
index 5396c26028db..4d258876bc2a 100644
--- a/net-www/skipstone/skipstone-0.8.3.ebuild
+++ b/net-www/skipstone/skipstone-0.8.3.ebuild
@@ -1,53 +1,44 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/skipstone/skipstone-0.8.3.ebuild,v 1.8 2002/11/03 05:07:18 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/skipstone/skipstone-0.8.3.ebuild,v 1.9 2002/12/05 15:45:28 vapier Exp $
-IUSE="nls"
-
-S=${WORKDIR}/${P}
DESCRIPTION="GTK+ based web browser based on the Mozilla engine"
SRC_URI="http://www.muhri.net/skipstone/${P}.tar.gz"
HOMEPAGE="http://www.muhri.net/skipstone/"
+
KEYWORDS="x86 ppc sparc sparc64"
SLOT="0"
LICENSE="GPL-2"
+IUSE="nls"
-DEPEND="=net-www/mozilla-0.9.9*
+DEPEND="net-www/mozilla
=x11-libs/gtk+-1.2*"
-
RDEPEND="${DEPEND}
nls? ( sys-devel/gettext )"
src_unpack() {
-
unpack ${A}
- use nls && ( \
+ if [ `use nls` ] ; then
cd ${S}/src
xgettext -k_ -kN_ ../src/*.[ch] -o ../locale/skipstone.pot
# Now we apply a patch to rid the files of duplicate translations
cd ${WORKDIR}
patch -p0 < ${FILESDIR}/${PN}-gentoo.patch
- )
+ fi
}
src_compile() {
-
local myconf
- use nls \
- && myconf="${myconf} --enable-nls"
+ use nls && myconf="${myconf} --enable-nls"
- econf ${myconf} || die
-
- make \
- PREFIX="/usr/lib/mozilla" || die
+ econf ${myconf}
+ make PREFIX="/usr/lib/mozilla" || die
}
-src_install () {
-
+src_install() {
einstall \
PREFIX=${D}/usr \
- LOCALEDIR=${D}/usr/share/locale \
- || die
+ LOCALEDIR=${D}/usr/share/locale
dodoc AUTHORS COPYING README README.copying
}
diff --git a/sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild b/sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild
index be012517ec40..aa3e0db0b02d 100644
--- a/sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild
+++ b/sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild
@@ -1,44 +1,38 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild,v 1.1 2002/11/02 07:51:43 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/linux-ntfs/linux-ntfs-1.6.0.ebuild,v 1.2 2002/12/05 15:46:35 vapier Exp $
DESCRIPTION="Utilities and library for accessing NTFS filesystems"
HOMEPAGE="http://linux-ntfs.sourceforge.net/"
-
-S=${WORKDIR}/${P}
SRC_URI="mirror://sourceforge/${PN}/${PN}-${PV}.tar.gz"
-DEPEND=">=sys-devel/gcc-2.96"
+
+DEPEND=">=sys-devel/gcc-2.95"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86"
src_unpack() {
- unpack ${A} || die
+ unpack ${A}
cd ${S} || die
patch -p0 <${FILESDIR}/${P}-gcc3.2.patch || die
}
src_compile() {
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die
+ econf
emake || die
}
src_install() {
make DESTDIR=${D} install || die
- # a normal user cannot run ntfsfix
- cd ${D}
- mv usr/bin/ntfsfix usr/sbin
- rm -rf usr/bin
- cd ${S}
-
# lot's of docs (a good thing :)
dodoc CREDITS ChangeLog NEWS README TODO.include TODO.mkntfs TODO.ntfsfix \
doc/attribute_definitions doc/attributes.txt doc/compression.txt \
doc/system_files.txt doc/system_security_descriptors.txt \
doc/tunable_settings
+
+ # a normal user cannot run ntfsfix
+ cd ${D}
+ mv usr/bin/ntfsfix usr/sbin
+ rm -rf usr/bin
}