summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/jruby/ChangeLog6
-rw-r--r--dev-java/jruby/files/jruby-1.4.0-bindir.patch13
-rw-r--r--dev-java/jruby/jruby-1.4.0-r4.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/dev-java/jruby/ChangeLog b/dev-java/jruby/ChangeLog
index f7d11cbfa04a..8b2e34ff8ab7 100644
--- a/dev-java/jruby/ChangeLog
+++ b/dev-java/jruby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/jruby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/ChangeLog,v 1.52 2010/01/23 23:02:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/ChangeLog,v 1.53 2010/01/24 00:54:52 flameeyes Exp $
+
+ 24 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ jruby-1.4.0-r4.ebuild, +files/jruby-1.4.0-bindir.patch:
+ Add patch to fix one further issue (don't revbump just yet).
*jruby-1.4.0-r4 (23 Jan 2010)
diff --git a/dev-java/jruby/files/jruby-1.4.0-bindir.patch b/dev-java/jruby/files/jruby-1.4.0-bindir.patch
new file mode 100644
index 000000000000..cf736a62efca
--- /dev/null
+++ b/dev-java/jruby/files/jruby-1.4.0-bindir.patch
@@ -0,0 +1,13 @@
+Index: jruby-1.4.0/src/org/jruby/libraries/RbConfigLibrary.java
+===================================================================
+--- jruby-1.4.0.orig/src/org/jruby/libraries/RbConfigLibrary.java
++++ jruby-1.4.0/src/org/jruby/libraries/RbConfigLibrary.java
+@@ -113,7 +113,7 @@ public class RbConfigLibrary implements
+ } else {
+ normalizedHome = runtime.getJRubyHome();
+ }
+- setConfig(configHash, "bindir", new NormalizedFile(normalizedHome, "bin").getPath());
++ setConfig(configHash, "bindir", "/usr/bin");
+ setConfig(configHash, "RUBY_INSTALL_NAME", jrubyScript());
+ setConfig(configHash, "ruby_install_name", jrubyScript());
+ setConfig(configHash, "SHELL", jrubyShell());
diff --git a/dev-java/jruby/jruby-1.4.0-r4.ebuild b/dev-java/jruby/jruby-1.4.0-r4.ebuild
index 316025187511..a7abb10cfed5 100644
--- a/dev-java/jruby/jruby-1.4.0-r4.ebuild
+++ b/dev-java/jruby/jruby-1.4.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/jruby-1.4.0-r4.ebuild,v 1.1 2010/01/23 23:02:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jruby/jruby-1.4.0-r4.ebuild,v 1.2 2010/01/24 00:54:52 flameeyes Exp $
EAPI="2"
JAVA_PKG_IUSE="doc source test"
@@ -94,6 +94,7 @@ java_prepare() {
epatch "${FILESDIR}/ftype-test-fixes.patch"
epatch "${FILESDIR}/user-test-fixes.patch"
epatch "${FILESDIR}"/${P}-system-jars.patch
+ epatch "${FILESDIR}"/${P}-bindir.patch
# We don't need to use Retroweaver. There is a jarjar and a regular jar
# target but even with jarjarclean, both are a pain. The latter target