summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-accessibility/speech-tools/ChangeLog9
-rw-r--r--app-accessibility/speech-tools/files/digest-speech-tools-1.2.95_beta-r13
-rw-r--r--app-accessibility/speech-tools/speech-tools-1.2.95_beta-r1.ebuild104
3 files changed, 115 insertions, 1 deletions
diff --git a/app-accessibility/speech-tools/ChangeLog b/app-accessibility/speech-tools/ChangeLog
index 62b7906dde1a..af662674956e 100644
--- a/app-accessibility/speech-tools/ChangeLog
+++ b/app-accessibility/speech-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/speech-tools
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-tools/ChangeLog,v 1.38 2006/09/21 04:36:35 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-tools/ChangeLog,v 1.39 2006/09/24 15:52:38 williamh Exp $
+
+*speech-tools-1.2.95_beta-r1 (24 Sep 2006)
+
+ 24 Sep 2006; William Hubbs <williamh@gentoo.org>
+ +speech-tools-1.2.95_beta-r1.ebuild:
+ This rev bump fixes a typo in the shared lib installation portion of the ebuild
+ for bug #148851.
*speech-tools-1.2.95_beta (21 Sep 2006)
diff --git a/app-accessibility/speech-tools/files/digest-speech-tools-1.2.95_beta-r1 b/app-accessibility/speech-tools/files/digest-speech-tools-1.2.95_beta-r1
new file mode 100644
index 000000000000..ad4a33cf98f5
--- /dev/null
+++ b/app-accessibility/speech-tools/files/digest-speech-tools-1.2.95_beta-r1
@@ -0,0 +1,3 @@
+MD5 4a0a58d8c4bafaee9f0a913372ded8bd speech_tools-1.2.95-beta.tar.gz 1281274
+RMD160 874b9e6d35bf8a59aeacd3d5b149e24e2a490008 speech_tools-1.2.95-beta.tar.gz 1281274
+SHA256 d9d0693ed57ba1f6c9471a43fe60fb1b728683fe6f820e98ef2be13bbd1fe772 speech_tools-1.2.95-beta.tar.gz 1281274
diff --git a/app-accessibility/speech-tools/speech-tools-1.2.95_beta-r1.ebuild b/app-accessibility/speech-tools/speech-tools-1.2.95_beta-r1.ebuild
new file mode 100644
index 000000000000..57226d1b4b09
--- /dev/null
+++ b/app-accessibility/speech-tools/speech-tools-1.2.95_beta-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-tools/speech-tools-1.2.95_beta-r1.ebuild,v 1.1 2006/09/24 15:52:38 williamh Exp $
+
+IUSE="esd X"
+
+inherit eutils fixheadtails toolchain-funcs
+
+MY_P=${P/speech-/speech_}
+MY_P=${MY_P/_beta/-beta}
+
+DESCRIPTION="Speech tools for Festival Text to Speech engine"
+HOMEPAGE="http://www.cstr.ed.ac.uk/"
+CSTR="http://www.cstr.ed.ac.uk/download/festival/1.95"
+SRC_URI="${CSTR}/${MY_P}.tar.gz"
+
+LICENSE="FESTIVAL BSD as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ app-arch/cpio
+ sys-apps/findutils
+ esd? ( media-sound/esound )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt )
+ !<app-accessibility/festival-1.95_beta
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/speech_tools"
+
+src_unpack() {
+ unpack ${A}
+
+# set the compiler flags.
+ sed -i -e 's:-O3:$(OPTIMISE_CXXFLAGS):' ${S}/base_class/Makefile
+
+ # Compile fix for #41329.
+ sed -i -e 's/-fpic/-fPIC/' ${S}/config/compilers/gcc_defaults.mak
+
+ sed -i -e 's/# \(SHARED=1\)/\1/' ${S}/config/config.in
+ use esd && sed -i -e 's/# \(INCLUDE_MODULES += ESD_AUDIO\)/\1/' ${S}/config/config.in
+ use X || sed -i -e 's/-lX11 -lXt//' ${S}/config/modules/esd_audio.mak
+
+ # gcc 4.1 compatibility patches
+ epatch ${FILESDIR}/${P}-gcc41.patch
+ epatch ${FILESDIR}/${P}-gcc41-amd64.patch
+ epatch ${FILESDIR}/${P}-gcc41-amd64-int-pointer.patch
+}
+
+src_compile() {
+ econf || die
+ emake -j1 OPTIMISE_CXXFLAGS="${CXXFLAGS}" OPTIMISE_CCFLAGS="${CFLAGS}" CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die
+}
+
+src_install() {
+ dolib.so ${S}/lib/{libestbase.so.1.2.95.1,libeststring.so.1.2}
+ dosym /usr/$(get_libdir)/libestbase.so.1.2.95.1 /usr/$(get_libdir)/libestbase.so
+ dosym /usr/$(get_libdir)/libeststring.so.1.2 /usr/$(get_libdir)/libeststring.so
+ dolib.a ${S}/lib/{libestbase.a,libestools.a,libeststring.a}
+
+ cd ${S}/bin
+ for file in *; do
+ [ "${file}" = "Makefile" ] && continue
+ dobin ${file}
+ dstfile="/usr/bin/${file}"
+ dosed "s:${S}/testsuite/data:/usr/share/speech-tools/testsuite:g" ${dstfile}
+ dosed "s:${S}/bin:/usr/libexec/speech-tools:g" ${dstfile}
+ dosed "s:${S}/main:/usr/libexec/speech-tools:g" ${dstfile}
+
+ # This just changes LD_LIBRARY_PATH
+ dosed "s:${S}/lib:/usr/$(get_libdir):g" ${dstfile}
+ done
+
+ exeinto /usr/libexec/speech-tools
+ for file in `find ${S}/main -perm +100 -type f`; do
+ doexe ${file}
+ done
+
+ insinto /usr/share/speech-tools/lib/siod
+ doins ${S}/lib/siod/*
+
+ insinto /usr/share/doc/${PF}/example_data
+ doins ${S}/lib/example_data/*
+
+ cd ${S}
+ find config -print | cpio -pmd ${D}/usr/share/speech-tools || die "Unable to install config files"
+
+ dodir /usr/include/speech-tools
+ cd ${S}/include
+ find . -print | cpio -pmd ${D}/usr/include/speech-tools || die "Unable to install include files"
+ dosym /usr/include/speech-tools /usr/share/speech-tools/include
+
+ chown -R root:0 ${D}
+
+ find ${D}/usr/share/speech-tools/config -type f | xargs sed -i -e 's/-ltermcap/-lncurses/g'
+
+ #doenvd ${FILESDIR}/58speech-tools
+
+ dodoc ${S}/{README,INSTALL}
+ dodoc ${S}/lib/cstrutt.dtd
+}