summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/bash/ChangeLog7
-rw-r--r--app-shells/bash/bash-3.1_p17.ebuild10
-rw-r--r--app-shells/bash/files/dot-bashrc4
3 files changed, 16 insertions, 5 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 8b22d2f354b1..a27684731627 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.106 2006/07/20 06:40:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.107 2006/08/01 19:59:06 flameeyes Exp $
+
+ 01 Aug 2006; Diego Pettenò <flameeyes@gentoo.org> files/dot-bashrc,
+ bash-3.1_p17.ebuild:
+ Don't make the ls alias when not using GNU userland, or it will break;
+ export CLICOLOR for Gentoo/FreeBSD compatibility.
20 Jul 2006; Mike Frysinger <vapier@gentoo.org> files/bashrc:
Enable histappend option by default #139609 by Trenton D. Adams and add
diff --git a/app-shells/bash/bash-3.1_p17.ebuild b/app-shells/bash/bash-3.1_p17.ebuild
index bfaf2e1655cd..792a2de6859c 100644
--- a/app-shells/bash/bash-3.1_p17.ebuild
+++ b/app-shells/bash/bash-3.1_p17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p17.ebuild,v 1.2 2006/05/06 00:58:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p17.ebuild,v 1.3 2006/08/01 19:59:06 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -108,7 +108,7 @@ src_compile() {
--disable-profiling \
--without-gnu-malloc \
${myconf} || die
- emake -j1 || die "make failed" # see bug 102426
+ emake -j1 || die "make failed" # see bug 102426
}
src_install() {
@@ -126,6 +126,10 @@ src_install() {
newins "${FILESDIR}"/dot-${f} .${f}
done
+ if use userland_GNU; then
+ sed -i -e 's:^#GNU#::' "${D}/etc/skel/.bashrc"
+ fi
+
if use build ; then
rm -rf "${D}"/usr
else
@@ -141,7 +145,7 @@ pkg_preinst() {
mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
fi
- # our bash_logout is just a place holder so dont
+ # our bash_logout is just a place holder so dont
# force users to go through etc-update all the time
if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
rm -f "${D}"/etc/bash/bash_logout
diff --git a/app-shells/bash/files/dot-bashrc b/app-shells/bash/files/dot-bashrc
index 28b9cc4e1bff..0191f878323c 100644
--- a/app-shells/bash/files/dot-bashrc
+++ b/app-shells/bash/files/dot-bashrc
@@ -21,7 +21,9 @@ elif [[ -f /etc/DIR_COLORS ]] ; then
eval $(dircolors -b /etc/DIR_COLORS)
fi
-alias ls='ls --color=auto'
+export CLICOLOR=1 # For FreeBSD
+
+#GNU#alias ls='ls --color=auto'
alias grep='grep --colour=auto'
# Change the window title of X terminals