summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/WWW-Mechanize/ChangeLog14
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.0301.ebuild8
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.04.ebuild8
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.12.ebuild8
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.16.ebuild8
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.18.ebuild8
6 files changed, 38 insertions, 16 deletions
diff --git a/dev-perl/WWW-Mechanize/ChangeLog b/dev-perl/WWW-Mechanize/ChangeLog
index 5b5d58b2ea6c..f556d1aa1596 100644
--- a/dev-perl/WWW-Mechanize/ChangeLog
+++ b/dev-perl/WWW-Mechanize/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-perl/WWW-Mechanize
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.29 2006/07/16 15:56:31 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.30 2006/08/06 01:04:47 mcummings Exp $
+
+ 06 Aug 2006; Michael Cummings <mcummings@gentoo.org>
+ WWW-Mechanize-1.04.ebuild, WWW-Mechanize-1.12.ebuild,
+ WWW-Mechanize-1.16.ebuild, WWW-Mechanize-1.18.ebuild,
+ WWW-Mechanize-1.0301.ebuild:
+ Accidently lost rdeps. recoverd.
+
+ 06 Aug 2006; Michael Cummings <mcummings@gentoo.org>
+ WWW-Mechanize-1.04.ebuild, WWW-Mechanize-1.12.ebuild,
+ WWW-Mechanize-1.16.ebuild, WWW-Mechanize-1.18.ebuild,
+ WWW-Mechanize-1.0301.ebuild:
+ Adding perl dep; fixed DEPEND
16 Jul 2006; Tobias Scherbaum <dertobi123@gentoo.org>
WWW-Mechanize-1.18.ebuild:
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.0301.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.0301.ebuild
index f9d6175ceae2..751be90f536b 100644
--- a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.0301.ebuild
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.0301.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.0301.ebuild,v 1.10 2006/07/10 22:52:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.0301.ebuild,v 1.11 2006/08/06 01:04:47 mcummings Exp $
inherit perl-module
@@ -20,9 +20,11 @@ KEYWORDS="amd64 ia64 ppc sparc x86"
DEPEND="dev-perl/IO-Socket-SSL
>=dev-perl/libwww-perl-5.76
dev-perl/URI
- dev-perl/HTML-Parser"
+ dev-perl/HTML-Parser
+ dev-lang/perl"
RDEPEND="${DEPEND}"
src_compile() {
echo "y" | perl-module_src_compile
-} \ No newline at end of file
+}
+
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.04.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.04.ebuild
index 67c34453a5e7..02c93b5a541d 100644
--- a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.04.ebuild
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.04.ebuild,v 1.7 2006/07/05 13:04:59 ian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.04.ebuild,v 1.8 2006/08/06 01:04:47 mcummings Exp $
inherit perl-module
@@ -15,9 +15,11 @@ KEYWORDS="amd64 ppc sparc x86"
DEPEND="dev-perl/IO-Socket-SSL
>=dev-perl/libwww-perl-5.76
dev-perl/URI
- dev-perl/HTML-Parser"
+ dev-perl/HTML-Parser
+ dev-lang/perl"
RDEPEND="${DEPEND}"
src_compile() {
echo "y" | perl-module_src_compile
-} \ No newline at end of file
+}
+
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.12.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.12.ebuild
index 2edc7e440d4f..c2cba9a519dc 100644
--- a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.12.ebuild
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.12.ebuild,v 1.7 2006/07/05 13:04:59 ian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.12.ebuild,v 1.8 2006/08/06 01:04:47 mcummings Exp $
inherit perl-module
@@ -15,9 +15,11 @@ KEYWORDS="~amd64 ppc sparc x86"
DEPEND="dev-perl/IO-Socket-SSL
>=dev-perl/libwww-perl-5.76
dev-perl/URI
- dev-perl/HTML-Parser"
+ dev-perl/HTML-Parser
+ dev-lang/perl"
RDEPEND="${DEPEND}"
src_compile() {
echo "y" | perl-module_src_compile
-} \ No newline at end of file
+}
+
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.16.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.16.ebuild
index 2a3f45b78c3b..bb8f8a187601 100644
--- a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.16.ebuild
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.16.ebuild,v 1.5 2006/07/05 13:04:59 ian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.16.ebuild,v 1.6 2006/08/06 01:04:47 mcummings Exp $
inherit perl-module
@@ -15,9 +15,11 @@ KEYWORDS="amd64 ppc sparc x86"
DEPEND="dev-perl/IO-Socket-SSL
>=dev-perl/libwww-perl-5.76
dev-perl/URI
- dev-perl/HTML-Parser"
+ dev-perl/HTML-Parser
+ dev-lang/perl"
RDEPEND="${DEPEND}"
src_compile() {
echo "y" | perl-module_src_compile
-} \ No newline at end of file
+}
+
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.18.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.18.ebuild
index ed7ef6357d54..8c80a98bb1ab 100644
--- a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.18.ebuild
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.18.ebuild,v 1.5 2006/07/16 15:56:31 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.18.ebuild,v 1.6 2006/08/06 01:04:47 mcummings Exp $
inherit perl-module
@@ -19,7 +19,10 @@ KEYWORDS="~amd64 ppc sparc ~x86"
# configure to run the local tests, but not the ones which access the Internet
myconf="--local --mech-dump --nolive"
-RDEPEND="dev-perl/IO-Socket-SSL
+DEPEND="${RDEPEND}"
+
+RDEPEND="dev-lang/perl
+ dev-perl/IO-Socket-SSL
>=dev-perl/libwww-perl-5.76
>=dev-perl/URI-1.25
>=dev-perl/HTML-Parser-3.34
@@ -29,4 +32,3 @@ RDEPEND="dev-perl/IO-Socket-SSL
dev-perl/Test-Warn
dev-perl/Test-Memory-Cycle )"
-DEPEND="${RDEPEND}"