summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/nano/ChangeLog6
-rw-r--r--app-editors/nano/files/nanohupterm.patch16
-rw-r--r--app-editors/nano/nano-1.2.1.ebuild8
-rw-r--r--app-editors/nano/nano-1.2.2.ebuild3
4 files changed, 29 insertions, 4 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index cb7d808f5ec9..a410f758e8a3 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,10 +1,12 @@
# ChangeLog for app-editors/nano
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.37 2003/09/30 17:50:01 kumba Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.38 2003/10/02 07:00:49 vapier Exp $
*nano-1.2.2 (18 Aug 2003)
+ 02 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add patch to fix run away nano's #17878.
+
30 Sep 2003; Joshua Kinard <kumba@gentoo.org> nano-1.2.2.ebuild:
Changed ~mips to mips in KEYWORDS
diff --git a/app-editors/nano/files/nanohupterm.patch b/app-editors/nano/files/nanohupterm.patch
new file mode 100644
index 000000000000..97e7a7717377
--- /dev/null
+++ b/app-editors/nano/files/nanohupterm.patch
@@ -0,0 +1,16 @@
+diff -ur nano/src/nano.c nano-fixed/src/nano.c
+--- nano/src/nano.c 2003-09-28 17:26:49.000000000 -0400
++++ nano-fixed/src/nano.c 2003-09-29 01:18:16.000000000 -0400
+@@ -2852,6 +2852,12 @@
+ /* Restore the terminal settings for the disabled keys */
+ tcsetattr(0, TCSANOW, &oldterm);
+
++ /* Trap SIGHUP and SIGTERM so we can properly deal with them while
++ suspended */
++ act.sa_handler = handle_hupterm;
++ sigaction(SIGHUP, &act, NULL);
++ sigaction(SIGTERM, &act, NULL);
++
+ /* We used to re-enable the default SIG_DFL and raise SIGTSTP, but
+ then we could be (and were) interrupted in the middle of the call.
+ So we do it the mutt way instead */
diff --git a/app-editors/nano/nano-1.2.1.ebuild b/app-editors/nano/nano-1.2.1.ebuild
index 81806deee1e6..152409532be9 100644
--- a/app-editors/nano/nano-1.2.1.ebuild
+++ b/app-editors/nano/nano-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.2.1.ebuild,v 1.8 2003/07/22 13:38:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.2.1.ebuild,v 1.9 2003/10/02 07:00:49 vapier Exp $
MY_P=${PN}-${PV/_}
DESCRIPTION="GNU GPL'd Pico clone with more functionality"
@@ -18,6 +18,12 @@ PROVIDE="virtual/editor"
S=${WORKDIR}/${MY_P}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/nanohupterm.patch
+}
+
src_compile() {
use build && myconf="${myconf} --disable-wrapping-as-root"
diff --git a/app-editors/nano/nano-1.2.2.ebuild b/app-editors/nano/nano-1.2.2.ebuild
index e6b91f5a72a3..b421614d0dc2 100644
--- a/app-editors/nano/nano-1.2.2.ebuild
+++ b/app-editors/nano/nano-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.2.2.ebuild,v 1.9 2003/09/30 17:50:01 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.2.2.ebuild,v 1.10 2003/10/02 07:00:49 vapier Exp $
inherit eutils
@@ -24,6 +24,7 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/nanohupterm.patch
epatch ${FILESDIR}/${PV}-wsconvert.patch
}