summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/ntfs3g/ChangeLog7
-rw-r--r--sys-fs/ntfs3g/ntfs3g-1.2531.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-fs/ntfs3g/ChangeLog b/sys-fs/ntfs3g/ChangeLog
index 510e3ce859d8..ff4af4588cdd 100644
--- a/sys-fs/ntfs3g/ChangeLog
+++ b/sys-fs/ntfs3g/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ntfs3g
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.65 2008/05/07 02:02:14 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ChangeLog,v 1.66 2008/06/03 17:58:13 chutzpah Exp $
+
+*ntfs3g-1.2531 (03 Jun 2008)
+
+ 03 Jun 2008; Patrick McLean <chutzpah@gentoo.org> +ntfs3g-1.2531.ebuild:
+ Version bump (bug #224481).
*ntfs3g-1.2506 (07 May 2008)
diff --git a/sys-fs/ntfs3g/ntfs3g-1.2531.ebuild b/sys-fs/ntfs3g/ntfs3g-1.2531.ebuild
new file mode 100644
index 000000000000..7ee94a5dc3ea
--- /dev/null
+++ b/sys-fs/ntfs3g/ntfs3g-1.2531.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.2531.ebuild,v 1.1 2008/06/03 17:58:13 chutzpah Exp $
+
+MY_PN="${PN/3g/-3g}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Open source read-write NTFS driver that runs under FUSE"
+HOMEPAGE="http://www.ntfs-3g.org"
+SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug suid"
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --enable-ldscript \
+ --disable-ldconfig \
+ $(use_enable debug)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ prepalldocs
+ dodoc AUTHORS ChangeLog CREDITS
+
+ use suid && fperms u+s "/bin/${MY_PN}"
+}
+
+pkg_postinst() {
+ if use suid; then
+ ewarn
+ ewarn "You have chosen to install ${PN} with the binary setuid root. This"
+ ewarn "means that if there any undetected vulnerabilities in the binary,"
+ ewarn "then local users may be able to gain root access on your machine."
+ ewarn
+ fi
+}