summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/urwid/ChangeLog9
-rw-r--r--dev-python/urwid/urwid-1.0.0.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index a28cfb44bc57..03f93fe358e8 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/urwid
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.43 2010/05/23 18:15:38 pacho Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.44 2011/09/22 19:26:41 radhermit Exp $
+
+*urwid-1.0.0 (22 Sep 2011)
+
+ 22 Sep 2011; Tim Harder <radhermit@gentoo.org> +urwid-1.0.0.ebuild:
+ Version bump.
23 May 2010; Pacho Ramos <pacho@gentoo.org> urwid-0.9.9.1.ebuild:
stable amd64, bug 307259
diff --git a/dev-python/urwid/urwid-1.0.0.ebuild b/dev-python/urwid/urwid-1.0.0.ebuild
new file mode 100644
index 000000000000..a8494e761380
--- /dev/null
+++ b/dev-python/urwid/urwid-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-1.0.0.ebuild,v 1.1 2011/09/22 19:26:41 radhermit Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python."
+HOMEPAGE="http://excess.org/urwid/ http://pypi.python.org/pypi/urwid"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+src_install() {
+ distutils_src_install
+
+ dohtml tutorial.html reference.html
+
+ if use examples ; then
+ docinto examples
+ dodoc bigtext.py browse.py calc.py dialog.py edit.py \
+ fib.py graph.py input_test.py tour.py
+ fi
+}