summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-plugins/wmlaptop/ChangeLog5
-rw-r--r--x11-plugins/wmlaptop/wmlaptop-1.3.ebuild17
2 files changed, 16 insertions, 6 deletions
diff --git a/x11-plugins/wmlaptop/ChangeLog b/x11-plugins/wmlaptop/ChangeLog
index 3676e3616f27..9042f05fb43b 100644
--- a/x11-plugins/wmlaptop/ChangeLog
+++ b/x11-plugins/wmlaptop/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmlaptop
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/ChangeLog,v 1.7 2007/07/22 04:56:29 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/ChangeLog,v 1.8 2009/01/14 15:54:35 s4t4n Exp $
+
+ 14 Jan 2009; Michele Noberasco <s4t4n@gentoo.org>; wmlaptop-1.3.ebuild:
+ Prevent automatic stripping of binaries. Closes bug #252109.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; wmlaptop-1.3.ebuild:
Drop virtual/x11 references.
diff --git a/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild b/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
index 6c889fe61c84..97681240dfe3 100644
--- a/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
+++ b/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild,v 1.6 2007/07/22 04:56:29 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlaptop/wmlaptop-1.3.ebuild,v 1.7 2009/01/14 15:54:35 s4t4n Exp $
IUSE=""
@@ -15,14 +15,21 @@ RDEPEND="x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm"
DEPEND="${RDEPEND}
- x11-proto/xextproto"
+ x11-proto/xextproto
+ >=sys-apps/sed-4.1.5-r1"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc x86"
+src_unpack() {
+ unpack ${A}
+
+ #Prevent automatic stripping of binaries. Closes bug #252109
+ sed -i 's/install -c -o 0 -g 0 -s -m/install -c -o 0 -g 0 -m/' "${S}/src/Makefile"
+}
+
src_compile() {
- cd ${S}
emake CFLAGS="${CFLAGS} -Wall" || die "Compilation failed"
}
@@ -33,5 +40,5 @@ src_install() {
dodoc AUTHORS README README.IT THANKS
insinto /usr/share/applications
- doins ${FILESDIR}/${PN}.desktop
+ doins "${FILESDIR}/${PN}.desktop"
}