summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/lxml/ChangeLog6
-rw-r--r--dev-python/lxml/lxml-3.2.1.ebuild12
2 files changed, 8 insertions, 10 deletions
diff --git a/dev-python/lxml/ChangeLog b/dev-python/lxml/ChangeLog
index a738b94679fb..b69a3cd17107 100644
--- a/dev-python/lxml/ChangeLog
+++ b/dev-python/lxml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/lxml
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.160 2013/05/22 21:40:54 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/ChangeLog,v 1.161 2013/05/22 22:27:57 idella4 Exp $
+
+ 22 May 2013; Ian Delaney <idella4@gentoo.org> lxml-3.2.0.ebuild,
+ lxml-3.2.1.ebuild:
+ Return arches in KEYWORDS to 1 line in -3.2.1
22 May 2013; Mike Gilbert <floppym@gentoo.org> lxml-3.2.0.ebuild:
Drop pypy support.
diff --git a/dev-python/lxml/lxml-3.2.1.ebuild b/dev-python/lxml/lxml-3.2.1.ebuild
index f0b090fe8131..4b213e56d466 100644
--- a/dev-python/lxml/lxml-3.2.1.ebuild
+++ b/dev-python/lxml/lxml-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.2.1.ebuild,v 1.2 2013/05/22 21:22:23 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-3.2.1.ebuild,v 1.3 2013/05/22 22:27:57 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
@@ -13,8 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD ElementTree GPL-2 PSF-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd \
- ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="beautifulsoup3 doc examples +threads"
# Note: lib{xml2,xslt} are used as C libraries, not Python modules.
@@ -63,12 +62,7 @@ python_install_all() {
local DOCS=( *.txt doc/*.txt )
local HTML_DOCS=( doc/html/. )
fi
+ use examples && local EXAMPLES=( samples/. )
distutils-r1_python_install_all
-
- if use examples; then
- docinto examples
- dodoc -r samples/*
- docompress -x /usr/share/doc/${PF}/examples
- fi
}