summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-perl/math-pari/ChangeLog8
-rw-r--r--dev-perl/math-pari/files/digest-math-pari-2.0107066
-rw-r--r--dev-perl/math-pari/math-pari-2.010706.ebuild26
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index 4fc537156ed5..d5762fb0a199 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/math-pari
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.23 2006/06/12 15:46:38 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.24 2006/06/23 20:17:40 mcummings Exp $
+
+*math-pari-2.010706 (23 Jun 2006)
+
+ 23 Jun 2006; Michael Cummings <mcummings@gentoo.org>
+ +math-pari-2.010706.ebuild:
+ Version bump upstream
12 Jun 2006; Michael Cummings <mcummings@gentoo.org>
math-pari-2.010702-r1.ebuild, math-pari-2.010704.ebuild:
diff --git a/dev-perl/math-pari/files/digest-math-pari-2.010706 b/dev-perl/math-pari/files/digest-math-pari-2.010706
new file mode 100644
index 000000000000..dafc1b30288f
--- /dev/null
+++ b/dev-perl/math-pari/files/digest-math-pari-2.010706
@@ -0,0 +1,6 @@
+MD5 5ed1fb49f246288a9899fa6ad1b7753c Math-Pari-2.010706.tar.gz 111692
+RMD160 ac2103ded269ba582acdb99314995c78edaa52d5 Math-Pari-2.010706.tar.gz 111692
+SHA256 ba546277afcbb072a11e7dbe74f44bd233d86ee310ef43fa945ac20dfc79ea02 Math-Pari-2.010706.tar.gz 111692
+MD5 357b7a42e89e2761a5367bbcbfcca5f2 pari-2.1.7.tgz 1542137
+RMD160 6d7ca649cdd457d96c12e1f9333143d496a78b7e pari-2.1.7.tgz 1542137
+SHA256 9142f2cdaf3083c8962f1a5c2bb0e9fe8915f7d9490c03312ac2361c7ea155fa pari-2.1.7.tgz 1542137
diff --git a/dev-perl/math-pari/math-pari-2.010706.ebuild b/dev-perl/math-pari/math-pari-2.010706.ebuild
new file mode 100644
index 000000000000..8aed1c9c6a3a
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.010706.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010706.ebuild,v 1.1 2006/06/23 20:17:40 mcummings Exp $
+
+inherit perl-module eutils
+
+MY_P="Math-Pari-${PV}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl interface to PARI"
+HOMEPAGE="http://www.cpan.org/authors/id/I/IL/ILYAZ/modules/${MY_P}.readme"
+SRC_URI="mirror://cpan/authors/id/I/IL/ILYAZ/modules/${MY_P}.tar.gz
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-2.1.7.tgz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+DEPEND="~sci-mathematics/pari-2.1.7"
+