summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/nfdump/ChangeLog6
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.10_p1.ebuild60
-rw-r--r--net-analyzer/nfdump/nfdump-1.6.9.ebuild60
3 files changed, 5 insertions, 121 deletions
diff --git a/net-analyzer/nfdump/ChangeLog b/net-analyzer/nfdump/ChangeLog
index 432afbaaa446..69e57afb6609 100644
--- a/net-analyzer/nfdump/ChangeLog
+++ b/net-analyzer/nfdump/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nfdump
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.39 2014/07/05 10:51:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/ChangeLog,v 1.40 2014/07/05 13:19:37 jer Exp $
+
+ 05 Jul 2014; Jeroen Roovers <jer@gentoo.org> -nfdump-1.6.9.ebuild,
+ -nfdump-1.6.10_p1.ebuild:
+ Old.
05 Jul 2014; Agostino Sarubbo <ago@gentoo.org> nfdump-1.6.12.ebuild:
Stable for x86, wrt bug #515278
diff --git a/net-analyzer/nfdump/nfdump-1.6.10_p1.ebuild b/net-analyzer/nfdump/nfdump-1.6.10_p1.ebuild
deleted file mode 100644
index a32db5024c31..000000000000
--- a/net-analyzer/nfdump/nfdump-1.6.10_p1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/nfdump-1.6.10_p1.ebuild,v 1.1 2013/08/14 12:48:31 jer Exp $
-
-EAPI=5
-inherit autotools eutils
-
-MY_P="${P/_/}"
-DESCRIPTION="A set of tools to collect and process netflow data"
-HOMEPAGE="http://nfdump.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfdump/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="compat15 debug ftconv nfprofile nftrack readpcap sflow"
-
-CDEPEND="
- ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
- nfprofile? ( net-analyzer/rrdtool )
- nftrack? ( net-analyzer/rrdtool )
- readpcap? ( net-libs/libpcap )
-"
-DEPEND="
- ${CDEPEND}
- sys-devel/flex
- virtual/yacc
-"
-RDEPEND="
- ${CDEPEND}
- dev-lang/perl
-"
-
-DOCS=( AUTHORS ChangeLog NEWS README )
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- if use ftconv; then
- sed -e '/ftbuild.h/d' -i bin/ft2nfdump.c || die
- sed \
- -e 's:lib\(/ftlib.h\):include\1:' \
- -e 's:libft.a:libft.so:' \
- \-i configure.in || die
- fi
- sed -i bin/Makefile.am -e '/^AM_CFLAGS/d' || die
- eautoreconf
-}
-
-src_configure() {
- # --without-ftconf is not handled well #322201
- econf \
- $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
- $(use nfprofile && echo --enable-nfprofile) \
- $(use nftrack && echo --enable-nftrack) \
- $(use_enable compat15) \
- $(use_enable debug devel) \
- $(use_enable readpcap) \
- $(use_enable sflow)
-}
diff --git a/net-analyzer/nfdump/nfdump-1.6.9.ebuild b/net-analyzer/nfdump/nfdump-1.6.9.ebuild
deleted file mode 100644
index 80dcf4246c92..000000000000
--- a/net-analyzer/nfdump/nfdump-1.6.9.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nfdump/nfdump-1.6.9.ebuild,v 1.3 2013/06/25 12:49:59 ago Exp $
-
-EAPI=5
-inherit autotools eutils
-
-MY_P="${P/_/}"
-DESCRIPTION="A set of tools to collect and process netflow data"
-HOMEPAGE="http://nfdump.sourceforge.net/"
-SRC_URI="mirror://sourceforge/nfdump/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="compat15 debug ftconv nfprofile nftrack readpcap sflow"
-
-CDEPEND="
- ftconv? ( sys-libs/zlib net-analyzer/flow-tools )
- nfprofile? ( net-analyzer/rrdtool )
- nftrack? ( net-analyzer/rrdtool )
- readpcap? ( net-libs/libpcap )
-"
-DEPEND="
- ${CDEPEND}
- sys-devel/flex
- virtual/yacc
-"
-RDEPEND="
- ${CDEPEND}
- dev-lang/perl
-"
-
-DOCS=( AUTHORS ChangeLog NEWS README )
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- if use ftconv; then
- sed -e '/ftbuild.h/d' -i bin/ft2nfdump.c || die
- sed \
- -e 's:lib\(/ftlib.h\):include\1:' \
- -e 's:libft.a:libft.so:' \
- \-i configure.in || die
- fi
- sed -i bin/Makefile.am -e '/^AM_CFLAGS/d' || die
- eautoreconf
-}
-
-src_configure() {
- # --without-ftconf is not handled well #322201
- econf \
- $(use ftconv && echo "--enable-ftconv --with-ftpath=/usr") \
- $(use nfprofile && echo --enable-nfprofile) \
- $(use nftrack && echo --enable-nftrack) \
- $(use_enable compat15) \
- $(use_enable debug devel) \
- $(use_enable readpcap) \
- $(use_enable sflow)
-}