summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-plugins/gnash/ChangeLog7
-rw-r--r--www-plugins/gnash/files/gnash-0.8.7-amf-include.patch44
-rw-r--r--www-plugins/gnash/gnash-0.8.7.ebuild7
3 files changed, 55 insertions, 3 deletions
diff --git a/www-plugins/gnash/ChangeLog b/www-plugins/gnash/ChangeLog
index 0fb8c87db88a..c983d5042896 100644
--- a/www-plugins/gnash/ChangeLog
+++ b/www-plugins/gnash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-plugins/gnash
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.22 2010/03/15 20:55:57 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/ChangeLog,v 1.23 2010/03/17 23:35:21 chithanh Exp $
+
+ 17 Mar 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ gnash-0.8.7.ebuild, +files/gnash-0.8.7-amf-include.patch:
+ Make agg the default renderer again, bug #309801. Attempt to fix build
+ with USE="lirc", bug #286933
*gnash-0.8.7 (15 Mar 2010)
diff --git a/www-plugins/gnash/files/gnash-0.8.7-amf-include.patch b/www-plugins/gnash/files/gnash-0.8.7-amf-include.patch
new file mode 100644
index 000000000000..2537ab06b4bc
--- /dev/null
+++ b/www-plugins/gnash/files/gnash-0.8.7-amf-include.patch
@@ -0,0 +1,44 @@
+diff -ur a/libnet/cque.h b/libnet/cque.h
+--- a/libnet/cque.h 2010-02-11 00:20:18.000000000 +0100
++++ b/libnet/cque.h 2010-03-18 00:05:37.000000000 +0100
+@@ -24,8 +24,9 @@
+ #include <boost/thread/condition.hpp>
+ #include <deque>
+
++#include "libamf/amf.h"
+ #include "getclocktime.hpp"
+-#include "buffer.h"
++#include "libamf/buffer.h"
+ #include "network.h"
+ #include "dsodefs.h" //For DSOEXPORT.
+
+diff -ur a/libnet/sshclient.h b/libnet/sshclient.h
+--- a/libnet/sshclient.h 2010-02-11 00:20:18.000000000 +0100
++++ b/libnet/sshclient.h 2010-03-18 00:03:49.000000000 +0100
+@@ -34,9 +34,10 @@
+ #include <libssh/sftp.h>
+ }
+
++#include "libamf/amf.h"
+ #include "cque.h"
+ #include "network.h"
+-#include "buffer.h"
++#include "libamf/buffer.h"
+
+ namespace gnash
+ {
+diff -ur a/libnet/sslclient.h b/libnet/sslclient.h
+--- a/libnet/sslclient.h 2010-02-11 00:20:17.000000000 +0100
++++ b/libnet/sslclient.h 2010-03-18 00:05:24.000000000 +0100
+@@ -38,9 +38,10 @@
+ #include <openssl/err.h>
+ #endif
+
++#include "libamf/amf.h"
+ #include "cque.h"
+ #include "network.h"
+-#include "buffer.h"
++#include "libamf/buffer.h"
+
+ namespace gnash
+ {
diff --git a/www-plugins/gnash/gnash-0.8.7.ebuild b/www-plugins/gnash/gnash-0.8.7.ebuild
index b4fdedde1a67..18c4bb6447a2 100644
--- a/www-plugins/gnash/gnash-0.8.7.ebuild
+++ b/www-plugins/gnash/gnash-0.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.7.ebuild,v 1.1 2010/03/15 20:55:57 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gnash/gnash-0.8.7.ebuild,v 1.2 2010/03/17 23:35:21 chithanh Exp $
EAPI="2"
CMAKE_REQUIRED="false"
@@ -17,7 +17,7 @@ SRC_URI="mirror://gnu/${PN}/${PV}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="agg cairo cygnal dbus doc +ffmpeg gnome gstreamer gtk kde lirc mysql +nls nsplugin +opengl python +sdl ssh ssl test video_cards_intel"
+IUSE="+agg cairo cygnal dbus doc +ffmpeg gnome gstreamer gtk kde lirc mysql +nls nsplugin opengl python +sdl ssh ssl test video_cards_intel"
RDEPEND=">=dev-libs/boost-1.35.0
dev-libs/expat
@@ -106,6 +106,9 @@ pkg_setup() {
src_prepare() {
local mozsdk_incdir=${S}/plugin/mozilla-sdk/include
+ # Fix missing includes of amr.h, bug #286933
+ epatch "${FILESDIR}"/${PN}-0.8.7-amf-include.patch
+
# Defines $(XPIDL) correctly using sdkdir variable from libxul.pc
epatch "${FILESDIR}"/${PN}-0.8.5-xpidl-sdkdir.patch