summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/install-xattr/ChangeLog5
-rw-r--r--sys-apps/install-xattr/install-xattr-0.1.ebuild11
2 files changed, 10 insertions, 6 deletions
diff --git a/sys-apps/install-xattr/ChangeLog b/sys-apps/install-xattr/ChangeLog
index 864349e092b1..1e5e70a04cc2 100644
--- a/sys-apps/install-xattr/ChangeLog
+++ b/sys-apps/install-xattr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/install-xattr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/ChangeLog,v 1.6 2014/02/22 07:17:47 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/ChangeLog,v 1.7 2014/02/22 15:36:21 blueness Exp $
+
+ 22 Feb 2014; Anthony G. Basile <blueness@gentoo.org> install-xattr-0.1.ebuild:
+ Fix bug #502076
22 Feb 2014; Agostino Sarubbo <ago@gentoo.org> install-xattr-0.1.ebuild:
Add ~sparc, wrt bug #501534
diff --git a/sys-apps/install-xattr/install-xattr-0.1.ebuild b/sys-apps/install-xattr/install-xattr-0.1.ebuild
index 53438380402d..f0a12c6e6856 100644
--- a/sys-apps/install-xattr/install-xattr-0.1.ebuild
+++ b/sys-apps/install-xattr/install-xattr-0.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/install-xattr-0.1.ebuild,v 1.6 2014/02/22 07:17:47 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/install-xattr/install-xattr-0.1.ebuild,v 1.7 2014/02/22 15:36:21 blueness Exp $
EAPI=5
+inherit toolchain-funcs
DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes."
HOMEPAGE="http://dev.gentoo.org/~blueness/install-xattr/"
@@ -11,13 +12,13 @@ SRC_URI="http://dev.gentoo.org/~blueness/install-xattr/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}
+src_prepare() {
+ tc-export CC
+}
+
# We need to fix how tests are done
src_test() {
true