summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libmpeg2/ChangeLog9
-rw-r--r--media-libs/libmpeg2/libmpeg2-0.5.1.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/media-libs/libmpeg2/ChangeLog b/media-libs/libmpeg2/ChangeLog
index a63af13664fb..83cc49802e00 100644
--- a/media-libs/libmpeg2/ChangeLog
+++ b/media-libs/libmpeg2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libmpeg2
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/ChangeLog,v 1.61 2007/10/26 00:49:21 beandog Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/ChangeLog,v 1.62 2008/07/18 16:05:16 aballier Exp $
+
+*libmpeg2-0.5.1 (18 Jul 2008)
+
+ 18 Jul 2008; Alexis Ballier <aballier@gentoo.org> +libmpeg2-0.5.1.ebuild:
+ version bump
26 Oct 2007; Steve Dibb <beandog@gentoo.org> libmpeg2-0.4.0b.ebuild,
libmpeg2-0.4.1.ebuild:
diff --git a/media-libs/libmpeg2/libmpeg2-0.5.1.ebuild b/media-libs/libmpeg2/libmpeg2-0.5.1.ebuild
new file mode 100644
index 000000000000..f307906f535d
--- /dev/null
+++ b/media-libs/libmpeg2/libmpeg2-0.5.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/libmpeg2-0.5.1.ebuild,v 1.1 2008/07/18 16:05:16 aballier Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="library for decoding mpeg-2 and mpeg-1 video"
+HOMEPAGE="http://libmpeg2.sourceforge.net/"
+SRC_URI="http://libmpeg2.sourceforge.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="sdl X"
+
+RDEPEND="sdl? ( media-libs/libsdl )
+ X? (
+ x11-libs/libXv
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xextproto )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix problem that the test for external symbols
+ # uses nm which also displays hidden symbols. Bug #130831
+ epatch "${FILESDIR}"/${PN}-0.4.1-use-readelf-for-test.patch
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --enable-shared \
+ --disable-dependency-tracking \
+ $(use_enable sdl) \
+ $(use_with X x)
+ emake \
+ OPT_CFLAGS="${CFLAGS}" \
+ MPEG2DEC_CFLAGS="${CFLAGS}" \
+ LIBMPEG2_CFLAGS="" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}