summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-benchmarks/iozone/ChangeLog7
-rw-r--r--app-benchmarks/iozone/files/digest-iozone-3.2793
-rw-r--r--app-benchmarks/iozone/iozone-3.279.ebuild79
3 files changed, 88 insertions, 1 deletions
diff --git a/app-benchmarks/iozone/ChangeLog b/app-benchmarks/iozone/ChangeLog
index 826e662df876..959bff8e6fcf 100644
--- a/app-benchmarks/iozone/ChangeLog
+++ b/app-benchmarks/iozone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/iozone
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/ChangeLog,v 1.30 2006/11/06 11:30:45 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/ChangeLog,v 1.31 2006/12/16 21:48:23 dragonheart Exp $
+
+*iozone-3.279 (16 Dec 2006)
+
+ 16 Dec 2006; Daniel Black <dragonheart@gentoo.org> +iozone-3.279.ebuild:
+ version bump
*iozone-3.267 (06 Nov 2006)
diff --git a/app-benchmarks/iozone/files/digest-iozone-3.279 b/app-benchmarks/iozone/files/digest-iozone-3.279
new file mode 100644
index 000000000000..4c2d6eeb4ee9
--- /dev/null
+++ b/app-benchmarks/iozone/files/digest-iozone-3.279
@@ -0,0 +1,3 @@
+MD5 4ae497fda323f97c1ce9b93b414df716 iozone3_279.tar 1515520
+RMD160 9a6bb6857f0b0603293d9c7f50268a54e8acff71 iozone3_279.tar 1515520
+SHA256 b947786752d5d6d53d634f915907e00cd4f1248c426efe2426b8fdee8a532387 iozone3_279.tar 1515520
diff --git a/app-benchmarks/iozone/iozone-3.279.ebuild b/app-benchmarks/iozone/iozone-3.279.ebuild
new file mode 100644
index 000000000000..685a2bed0d51
--- /dev/null
+++ b/app-benchmarks/iozone/iozone-3.279.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/iozone-3.279.ebuild,v 1.1 2006/12/16 21:48:23 dragonheart Exp $
+
+# TODO
+# -> linux-arm (32bit) <-
+# -> linux-AMD64 (64bit) <-
+# -> linux-ia64 (64bit) <-
+# -> linux-powerpc (32bit) <-
+# -> linux-powerpc64 (64bit) <-
+# -> linux-S390 (32bit) <-
+# -> linux-S390X (64bit) <-
+#
+# -> freebsd (32bit) <-
+# -> macosx (32bit) <-
+# -> netbsd (32bit) <-
+# -> openbsd (32bit) <-
+# -> openbsd-threads (32bit) <-
+#
+# ~ia64 ~s390 alpha(?) x86-fbsd
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Filesystem benchmarking program"
+HOMEPAGE="http://www.iozone.org/"
+SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/gcc
+ >=sys-apps/sed-4
+ virtual/libc"
+RDEPEND="virtual/libc"
+
+S=${WORKDIR}/${PN}${PV/./_}
+
+src_compile() {
+ cd src/current
+
+ # Options FIX
+ sed -i -e "s:CC =.*:CC =$(tc-getCC):g" \
+ -e "s:-O3:${CFLAGS}:g" makefile
+
+ case ${ARCH} in
+ x86|alpha) PLATFORM="linux";;
+ arm) PLATFORM="linux-arm";;
+ ppc) PLATFORM="linux-powerpc";;
+ ppc64) PLATFORM="linux-powerpc64";;
+ amd64) PLATFORM="linux-AMD64";;
+ ia64) PLATFORM="linux-ia64";;
+ s390) PLATFORM="linux-S390";;
+ x86-fbsd) PLATFORM="freebsd";;
+ *) PLATFORM="linux-${ARCH}";;
+ esac
+
+ emake ${PLATFORM} || die "Compile failed"
+}
+
+src_install() {
+ dosbin src/current/iozone
+ dodoc docs/I*
+ dodoc docs/Run_rules.doc
+ dodoc src/current/Changes.txt
+ doman docs/iozone.1
+
+ insinto /usr/share/doc/${PF}
+ cd src/current
+ doins Generate_Graphs Gnuplot.txt gengnuplot.sh gnu3d.dem
+
+ prepall
+}
+
+src_test() {
+ cd ${T}
+ ${S}/src/current/iozone testfile || die "self test failed"
+}