summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-misc/fcgiwrap/ChangeLog8
-rw-r--r--www-misc/fcgiwrap/fcgiwrap-1.0.3.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/www-misc/fcgiwrap/ChangeLog b/www-misc/fcgiwrap/ChangeLog
index da250ffbb70e..abd68bc37a3e 100644
--- a/www-misc/fcgiwrap/ChangeLog
+++ b/www-misc/fcgiwrap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-misc/fcgiwrap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/ChangeLog,v 1.2 2010/07/13 13:03:30 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/ChangeLog,v 1.3 2010/09/15 07:12:12 pva Exp $
+
+*fcgiwrap-1.0.3 (15 Sep 2010)
+
+ 15 Sep 2010; Peter Volkov <pva@gentoo.org> +fcgiwrap-1.0.3.ebuild:
+ Version bump, respect LDFLAGS, #336810 thank Diego E. 'Flameeyes' Pettenò
+ for report and Nikoli for the job.
13 Jul 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
metadata.xml:
diff --git a/www-misc/fcgiwrap/fcgiwrap-1.0.3.ebuild b/www-misc/fcgiwrap/fcgiwrap-1.0.3.ebuild
new file mode 100644
index 000000000000..5b2411c1c1d2
--- /dev/null
+++ b/www-misc/fcgiwrap/fcgiwrap-1.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-misc/fcgiwrap/fcgiwrap-1.0.3.ebuild,v 1.1 2010/09/15 07:12:12 pva Exp $
+
+EAPI="3"
+
+[[ ${PV} = *9999* ]] && VCS_ECLASS="git" || VCS_ECLASS=""
+inherit autotools ${VCS_ECLASS}
+
+DESCRIPTION="Simple FastCGI wrapper for CGI scripts (CGI support for nginx)"
+HOMEPAGE="http://nginx.localdomain.pl/wiki/FcgiWrap"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/gnosek/${PN}.git"
+
+ KEYWORDS=""
+else
+ MY_REV="58ec209"
+ SRC_URI="http://download.github.com/gnosek-${P}-4-g${MY_REV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/gnosek-${PN}-${MY_REV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="dev-libs/fcgi"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e '/man8dir = $(DESTDIR)/s/@prefix@//' \
+ -i Makefile.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+
+ dodoc README.rst
+}
+
+pkg_postinst() {
+ einfo 'You may want to install www-servers/spawn-fcgi to use with fcgiwrap.'
+}