summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/rb_libtorrent/ChangeLog7
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild17
2 files changed, 10 insertions, 14 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 44f0c8205b66..586b6e640e45 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.136 2012/10/23 22:02:10 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.137 2012/10/31 17:26:17 flameeyes Exp $
+
+ 31 Oct 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ rb_libtorrent-0.16.5.ebuild:
+ Simplify finding boost library so that it works with all versions, now that
+ it's unslotted.
*rb_libtorrent-0.16.5 (23 Oct 2012)
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild
index d7b97ebce477..ddf15f5f0312 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild,v 1.1 2012/10/23 22:02:10 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.5.ebuild,v 1.2 2012/10/31 17:26:17 flameeyes Exp $
EAPI="4"
PYTHON_DEPEND="python? 2:2.6"
@@ -43,17 +43,11 @@ src_prepare() {
src_configure() {
# use multi-threading versions of boost libs
- local BOOST_LIBS="--with-boost-system=boost_system-mt \
+ local myconf="--with-boost-system=boost_system-mt \
--with-boost-python=boost_python-${PYTHON_ABI}-mt"
- # detect boost version and location, bug 295474
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="${EPREFIX}/usr/include/boost-${BOOST_VER}"
- BOOST_LIB="${EPREFIX}/usr/$(get_libdir)/boost-${BOOST_VER}"
local LOGGING
- use debug && LOGGING="--enable-logging=verbose"
+ use debug && myconf+=" --enable-logging=verbose"
econf $(use_enable debug) \
$(use_enable test tests) \
@@ -61,10 +55,7 @@ src_configure() {
$(use_enable python python-binding) \
$(use_enable ssl encryption) \
$(use_enable static-libs static) \
- ${LOGGING} \
- --with-boost=${BOOST_INC} \
- --with-boost-libdir=${BOOST_LIB} \
- ${BOOST_LIBS}
+ ${myconf}
}
src_install() {