summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/webkit-gtk/ChangeLog6
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild19
2 files changed, 8 insertions, 17 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index fc3bbde13cd5..68a5ffaaffe3 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.63 2010/02/03 13:58:49 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.64 2010/02/12 21:19:37 pacho Exp $
+
+ 12 Feb 2010; Pacho Ramos <pacho@gentoo.org> webkit-gtk-1.1.15.4.ebuild:
+ Dropping pango USE flag since webkit uses pango by default since 1.1.x,
+ bug 301577
03 Feb 2010; Fabian Groffen <grobian@gentoo.org>
webkit-gtk-1.1.15.4.ebuild,
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild
index c03dc22058a1..050cea5c7eb3 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild,v 1.6 2010/02/03 20:13:51 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.1.15.4.ebuild,v 1.7 2010/02/12 21:19:37 pacho Exp $
EAPI="2"
@@ -15,7 +15,7 @@ LICENSE="LGPL-2 LGPL-2.1 BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
# geoclue
-IUSE="aqua coverage debug doc +gstreamer pango +websockets"
+IUSE="aqua coverage debug doc +gstreamer +websockets"
# use sqlite, svg by default
# dependency on >=x11-libs/gtk+-2.13 for gail
@@ -32,14 +32,11 @@ RDEPEND="
>=net-libs/libsoup-2.27.91
>=dev-db/sqlite-3
>=app-text/enchant-0.22
+ >=x11-libs/pango-1.12
gstreamer? (
media-libs/gstreamer:0.10
media-libs/gst-plugins-base:0.10 )
- pango? ( >=x11-libs/pango-1.12 )
- !pango? (
- media-libs/freetype:2
- media-libs/fontconfig )
"
DEPEND="${RDEPEND}
>=sys-devel/flex-2.5.33
@@ -85,16 +82,6 @@ src_configure() {
--enable-filters --enable-ruby
$(use aqua && echo "--with-target=quartz")"
- # USE-flag controlled font backend because upstream default is freetype
- # Remove USE-flag once font-backend becomes pango upstream
- if use pango; then
- ewarn "You have enabled the incomplete pango backend"
- ewarn "Please file any and all bugs *upstream*"
- myconf="${myconf} --with-font-backend=pango"
- else
- myconf="${myconf} --with-font-backend=freetype"
- fi
-
econf ${myconf}
}