summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-emulation/mupen64plus-core/ChangeLog5
-rw-r--r--games-emulation/mupen64plus-core/mupen64plus-core-2.0.ebuild9
2 files changed, 12 insertions, 2 deletions
diff --git a/games-emulation/mupen64plus-core/ChangeLog b/games-emulation/mupen64plus-core/ChangeLog
index 29e2ba0e0b21..7d22e7e9aa78 100644
--- a/games-emulation/mupen64plus-core/ChangeLog
+++ b/games-emulation/mupen64plus-core/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/mupen64plus-core
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-core/ChangeLog,v 1.1 2013/12/15 12:07:24 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-core/ChangeLog,v 1.2 2013/12/16 16:42:00 mgorny Exp $
+
+ 16 Dec 2013; Michał Górny <mgorny@gentoo.org> mupen64plus-core-2.0.ebuild:
+ Remove implicit CPU flags from the Makefiles. Support epatch_user.
*mupen64plus-core-2.0 (15 Dec 2013)
diff --git a/games-emulation/mupen64plus-core/mupen64plus-core-2.0.ebuild b/games-emulation/mupen64plus-core/mupen64plus-core-2.0.ebuild
index 1f650845adfe..86ddeac77299 100644
--- a/games-emulation/mupen64plus-core/mupen64plus-core-2.0.ebuild
+++ b/games-emulation/mupen64plus-core/mupen64plus-core-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-core/mupen64plus-core-2.0.ebuild,v 1.1 2013/12/15 12:07:24 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-core/mupen64plus-core-2.0.ebuild,v 1.2 2013/12/16 16:42:00 mgorny Exp $
EAPI=5
@@ -32,6 +32,13 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch_user
+
+ # avoid implicitly appending CPU flags
+ sed -i -e 's:-mmmx::g' -e 's:-msse::g' projects/unix/Makefile || die
+}
+
src_compile() {
MAKEARGS=(
# Note: please keep this in sync in all of mupen64plus-* packages