summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/astrolog/ChangeLog7
-rw-r--r--app-misc/astrolog/Manifest3
-rw-r--r--app-misc/astrolog/astrolog-5.40.ebuild58
-rw-r--r--app-misc/astrolog/files/digest-astrolog-5.401
-rw-r--r--app-misc/astrolog/metadata.xml14
5 files changed, 82 insertions, 1 deletions
diff --git a/app-misc/astrolog/ChangeLog b/app-misc/astrolog/ChangeLog
new file mode 100644
index 000000000000..b150c6364eca
--- /dev/null
+++ b/app-misc/astrolog/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for app-misc/astrolog
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header:
+
+*astrolog-5.40 (30 Jul 2003)
+
+ Initial ebuild created by Nicolai Lissner <nlissne@linux01.gwdg.de>
diff --git a/app-misc/astrolog/Manifest b/app-misc/astrolog/Manifest
index c37337b53218..8eb4c97d65ba 100644
--- a/app-misc/astrolog/Manifest
+++ b/app-misc/astrolog/Manifest
@@ -1,3 +1,4 @@
-MD5 c0d4a23722a80dd2f393c2f95173efbd astrolog-5.40.ebuild 1882
+MD5 01bd377aca6a7398dd9d7a5f4a6956bc astrolog-5.40.ebuild 1980
MD5 e54ba4834dbb07c55eed18779dcb4828 ChangeLog 225
+MD5 97eefe679218d90662c29006ad85eef0 metadata.xml 408
MD5 d6e3d805e13b735f1bc9665ccd43e858 files/digest-astrolog-5.40 58
diff --git a/app-misc/astrolog/astrolog-5.40.ebuild b/app-misc/astrolog/astrolog-5.40.ebuild
new file mode 100644
index 000000000000..469d226dd7f3
--- /dev/null
+++ b/app-misc/astrolog/astrolog-5.40.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/astrolog/astrolog-5.40.ebuild,v 1.1 2003/12/11 20:57:16 george Exp $
+
+DESCRIPTION="A many featured astrology chart calculation program"
+HOMEPAGE="http://www.astrolog.org/astrolog.htm"
+SRC_URI="http://www.astrolog.org/ftp/ast54unx.shr"
+LICENSE="astrolog"
+SLOT="0"
+
+# works fine on x86 - runs probably on other architectures, too
+KEYWORDS="~x86"
+
+IUSE="X"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ bash ${DISTDIR}/ast54unx.shr
+ # if we use X, we need to add -L/usr/X11R6/lib to compile succesful
+ use X && sed -i -e "s:-lm -lX11:-lm -lX11 -L/usr/X11R6/lib:g" Makefile
+
+ # if we do NOT use X, we disable it by removing the -lX11 from the Makefile
+ # and remove the "#define X11" and "#define MOUSE" from astrolog.h
+ use X || ( sed -i -e "s:-lm -lX11:-lm:g" Makefile
+ sed -i -e "s:#define X11:/*#define X11:g" astrolog.h
+ sed -i -e "s:#define MOUSE:/*#define MOUSE:g" astrolog.h )
+
+ # we use /usr/share/astrolog for config and (optional) ephemeris-data-files
+ sed -i -e "s:~/astrolog:/usr/share/astrolog:g" astrolog.h
+
+ # any user may have an own astrolog configfile
+ sed -i -e "s:astrolog.dat:astrolog.dat:g" astrolog.h
+
+ # include users CFLAGS
+ sed -i -e "s:= -O:= ${CFLAGS}":g Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin
+ cp astrolog ${D}/usr/bin/
+ dodoc Helpfile.540 README.1ST README.540 Update.540
+ dodir /usr/share/astrolog
+ cp astrolog.dat ${D}/usr/share/astrolog/
+}
+
+pkg_postinst() {
+ ewarn "There is a sample config file /usr/share/astrolog/astrolog.dat"
+ ewarn "astrolog looks in current dir for a file astrolog.dat before"
+ ewarn "using the file in /usr/share/astrolog"
+ ewarn "If you want extended accuracy of astrolog's calculations you"
+ ewarn "can emerge the optional package \"astrolog-ephemeris\" which"
+ ewarn "needs ~4.7 MB additional diskspace for the ephemeris-files"
+}
diff --git a/app-misc/astrolog/files/digest-astrolog-5.40 b/app-misc/astrolog/files/digest-astrolog-5.40
new file mode 100644
index 000000000000..be4ada6a84d5
--- /dev/null
+++ b/app-misc/astrolog/files/digest-astrolog-5.40
@@ -0,0 +1 @@
+MD5 3d604e013d8a7e2134bc637f17bb2857 ast54unx.shr 1465432
diff --git a/app-misc/astrolog/metadata.xml b/app-misc/astrolog/metadata.xml
new file mode 100644
index 000000000000..5341fd7efb90
--- /dev/null
+++ b/app-misc/astrolog/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+
+<maintainer>
+ <name>George Shapovalov</name>
+ <email>george@gentoo.org</email>
+ <description>I'll be taking care of it. But since we need to have a herd in metadata
+ I've put sci there, as it seems the most related one.
+ </description>
+</maintainer>
+
+</pkgmetadata>