summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-antivirus/clamav/ChangeLog9
-rw-r--r--app-antivirus/clamav/Manifest2
-rw-r--r--app-antivirus/clamav/clamav-0.75.1.ebuild57
-rw-r--r--app-antivirus/clamav/clamav-0.75.ebuild4
-rw-r--r--app-antivirus/clamav/files/clamd.rc15
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.75.11
6 files changed, 79 insertions, 9 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 5dbfff467f3f..2d1962803ff8 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.8 2004/07/23 07:52:38 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.9 2004/07/30 18:12:02 lordvan Exp $
+
+*clamav-0.75.1 (30 Jul 2004)
+
+ 30 Jul 2004; root <root@gentoo.org> clamav-0.75.1.ebuild, files/clamd.rc:
+ fixed bug in clamd.rc (thanks to Pavel Riha <Pavel.Riha@trilogic.cz> )
+ new version
+ marked 0.75 stable x86
*clamav-0.75 (23 Jul 2004)
diff --git a/app-antivirus/clamav/Manifest b/app-antivirus/clamav/Manifest
index 243128e78100..117245a88ed7 100644
--- a/app-antivirus/clamav/Manifest
+++ b/app-antivirus/clamav/Manifest
@@ -8,6 +8,7 @@ MD5 705e2c24baf6b7fb23b12d4310217f53 clamav-0.74.ebuild 1535
MD5 7e32edfd72887a57b16ecd73f0f7a1a0 metadata.xml 184
MD5 a70ffb4fce18f8220a95a2e0287e82eb ChangeLog 6017
MD5 c7e444875d160f86556d7948a5d93d95 clamav-0.75.ebuild 1535
+MD5 c7e444875d160f86556d7948a5d93d95 clamav-0.75.1.ebuild 1535
MD5 ad7d45b1be51c06986cb42c53e733d19 files/clamav-milter.README.gentoo 1311
MD5 e8dcbdecd955708ddc7c79399ffa6276 files/clamd.conf 166
MD5 9c52877a96f295b0402bad70bc4af358 files/clamd.rc 1385
@@ -19,3 +20,4 @@ MD5 2c7f2f8b0a3e7d16ecc154dd129188e3 files/digest-clamav-0.72 64
MD5 50b576f5cc3976c6bc0d9aa11a2d25a3 files/digest-clamav-0.73 64
MD5 6c57d7ce5871b55ba80e4ceb212fb536 files/digest-clamav-0.74 64
MD5 ca02cdeca3ca7b1d860522275a664567 files/digest-clamav-0.75 64
+MD5 f0090a77dc10ba3899900622336b8610 files/digest-clamav-0.75.1 66
diff --git a/app-antivirus/clamav/clamav-0.75.1.ebuild b/app-antivirus/clamav/clamav-0.75.1.ebuild
new file mode 100644
index 000000000000..1ad259132c51
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.75.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.75.1.ebuild,v 1.1 2004/07/30 18:12:02 lordvan Exp $
+
+inherit eutils flag-o-matic
+
+#MY_P="${PN}-0.70-rc"
+MY_P="${P}"
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/clamav/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64"
+IUSE="milter crypt"
+
+DEPEND="virtual/libc
+ crypt? ( >=dev-libs/gmp-4.1.2 )"
+PROVIDE="virtual/antivirus"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ enewgroup clamav
+ enewuser clamav -1 /bin/false /dev/null clamav
+ pwconv || die
+}
+
+src_compile() {
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
+
+ local myconf
+ use milter && myconf="--enable-milter"
+ econf ${myconf} --with-dbdir=/var/lib/clamav || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog TODO FAQ INSTALL
+ exeinto /etc/init.d ; newexe ${FILESDIR}/clamd.rc clamd
+ insinto /etc/conf.d ; newins ${FILESDIR}/clamd.conf clamd
+ dodoc ${FILESDIR}/clamav-milter.README.gentoo
+}
+
+pkg_postinst() {
+ einfo ""
+ ewarn "Warning: clamd and/or freshclam have not been restarted."
+ ewarn "You should restart them with: /etc/init.d/clamd restart"
+ einfo ""
+ if use milter ; then
+ einfo "For simple instructions howto setup the clamav-milter..."
+ einfo ""
+ einfo "less /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
+ fi
+}
diff --git a/app-antivirus/clamav/clamav-0.75.ebuild b/app-antivirus/clamav/clamav-0.75.ebuild
index 018f6b56f596..8ec8c6306508 100644
--- a/app-antivirus/clamav/clamav-0.75.ebuild
+++ b/app-antivirus/clamav/clamav-0.75.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.75.ebuild,v 1.1 2004/07/23 07:52:38 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.75.ebuild,v 1.2 2004/07/30 18:12:02 lordvan Exp $
inherit eutils flag-o-matic
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/clamav/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64"
+KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64"
IUSE="milter crypt"
DEPEND="virtual/libc
diff --git a/app-antivirus/clamav/files/clamd.rc b/app-antivirus/clamav/files/clamd.rc
index 7fa44eeb55d5..dd39b54e1e4e 100644
--- a/app-antivirus/clamav/files/clamd.rc
+++ b/app-antivirus/clamav/files/clamd.rc
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/files/clamd.rc,v 1.2 2004/07/14 21:23:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/files/clamd.rc,v 1.3 2004/07/30 18:12:02 lordvan Exp $
depend() {
need net
@@ -12,9 +12,10 @@ start() {
if [ -S "/tmp/clamd" ]; then
rm -f /tmp/clamd
fi
- if [ -n "${CLAMD_LOG}" -a ! -f "${CLAMD_LOG}" ]; then
+ if [ -n "$CLAMD_LOG}" -a ! -f "${CLAMD_LOG}" ]; then
touch "${CLAMD_LOG}"
chown clamav:clamav "${CLAMD_LOG}"
+ CLAMD_OPTS="${CLAMD_OPTS}${CLAMD_LOG}"
fi
ebegin "Starting clamd"
start-stop-daemon --start --quiet \
@@ -22,14 +23,16 @@ start() {
eend $? "Failed to start clamd"
fi
if [ "${START_FRESHCLAM}" = "yes" ]; then
- if [ -n "${FRESHCLAM_LOG}" -a ! -f "${FRESHCLAM_LOG}" ]; then
- touch "${FRESHCLAM_LOG}"
- chown clamav:clamav "${FRESHCLAM_LOG}"
+ if [ -n "${FRESHCLAM_LOG}" ]; then
+ if [ ! -f "${FRESHCLAM_LOG}" ]; then
+ touch "${FRESHCLAM_LOG}"
+ chown clamav:clamav "${FRESHCLAM_LOG}"
+ fi
FRESHCLAM_OPTS="${FRESHCLAM_OPTS} -l ${FRESHCLAM_LOG}"
fi
ebegin "Starting freshclam"
start-stop-daemon --start --quiet \
- --exec /usr/bin/freshclam -- ${FRESHCLAM_OPTS} -l ${FRESHCLAM_LOG}
+ --exec /usr/bin/freshclam -- ${FRESHCLAM_OPTS}
eend $? "Failed to start freshclam"
fi
}
diff --git a/app-antivirus/clamav/files/digest-clamav-0.75.1 b/app-antivirus/clamav/files/digest-clamav-0.75.1
new file mode 100644
index 000000000000..c411f8e1705e
--- /dev/null
+++ b/app-antivirus/clamav/files/digest-clamav-0.75.1
@@ -0,0 +1 @@
+MD5 2c85b7957eba9fd9e9ff8c2537ae006f clamav-0.75.1.tar.gz 2777319