summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/openexr/ChangeLog7
-rw-r--r--media-libs/openexr/openexr-2.2.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/media-libs/openexr/ChangeLog b/media-libs/openexr/ChangeLog
index 655c6bf9cfca..3c7b90052fb0 100644
--- a/media-libs/openexr/ChangeLog
+++ b/media-libs/openexr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/openexr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr/ChangeLog,v 1.96 2014/08/03 18:29:48 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr/ChangeLog,v 1.97 2014/08/22 22:17:36 ssuominen Exp $
+
+*openexr-2.2.0 (22 Aug 2014)
+
+ 22 Aug 2014; Samuli Suominen <ssuominen@gentoo.org> +openexr-2.2.0.ebuild:
+ Version bump.
03 Aug 2014; Christoph Junghans <ottxor@gentoo.org> openexr-2.1.0.ebuild:
added prefix support (bug #515454)
diff --git a/media-libs/openexr/openexr-2.2.0.ebuild b/media-libs/openexr/openexr-2.2.0.ebuild
new file mode 100644
index 000000000000..8275db256626
--- /dev/null
+++ b/media-libs/openexr/openexr-2.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openexr/openexr-2.2.0.ebuild,v 1.1 2014/08/22 22:17:36 ssuominen Exp $
+
+EAPI=5
+inherit autotools-multilib
+
+DESCRIPTION="ILM's OpenEXR high dynamic-range image file format libraries"
+HOMEPAGE="http://openexr.com/"
+SRC_URI="http://download.savannah.gnu.org/releases/openexr/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/22" # based on SONAME
+KEYWORDS="~alpha ~amd64 -arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="examples static-libs"
+
+RDEPEND=">=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}]
+ >=media-libs/ilmbase-${PV}:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ # Fix path for testsuite
+ sed -i -e "s:/var/tmp/:${T}:" IlmImfTest/tmpDir.h || die
+ autotools-multilib_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable examples imfexamples)
+ )
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install \
+ docdir="${EPREFIX}"/usr/share/doc/${PF}/pdf \
+ examplesdir="${EPREFIX}"/usr/share/doc/${PF}/examples
+
+ docompress -x /usr/share/doc/${PF}/examples
+ use examples || rm -rf "${ED}"/usr/share/doc/${PF}/examples
+}