summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libesmtp/libesmtp-0.8.6.ebuild28
-rw-r--r--net-mail/balsa/balsa-1.2.3.ebuild52
2 files changed, 80 insertions, 0 deletions
diff --git a/net-libs/libesmtp/libesmtp-0.8.6.ebuild b/net-libs/libesmtp/libesmtp-0.8.6.ebuild
new file mode 100644
index 000000000000..00e86180fa79
--- /dev/null
+++ b/net-libs/libesmtp/libesmtp-0.8.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libesmtp/libesmtp-0.8.6.ebuild,v 1.1 2001/12/20 15:35:51 chouser Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="libESMTP is a library that implements the client side of the SMTP protocol"
+SRC_URI="http://www.stafford.uklinux.net/libesmtp/${A}"
+HOMEPAGE="http://www.stafford.uklinux.net/libesmtp/index.html"
+
+DEPEND="virtual/glibc
+ >=sys-devel/libtool-1.3.5-r2
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_compile() {
+ local myconf
+ use ssl || myconf="$myconf --without-openssl"
+
+ ./configure --prefix=/usr --enable-require-all-recipients $myconf
+ assert "configure failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make prefix=${D}/usr install || die "make install failed"
+ dodoc AUTHORS COPYING COPYING.GPL INSTALL ChangeLog NEWS Notes README TODO doc/api.xml
+}
diff --git a/net-mail/balsa/balsa-1.2.3.ebuild b/net-mail/balsa/balsa-1.2.3.ebuild
new file mode 100644
index 000000000000..405e9960cb84
--- /dev/null
+++ b/net-mail/balsa/balsa-1.2.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke (blocke@shivan.org)
+# $Header: /var/cvsroot/gentoo-x86/net-mail/balsa/balsa-1.2.3.ebuild,v 1.1 2001/12/20 15:36:37 chouser Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="Balsa: email client for GNOME"
+SRC_URI="http://www.theochem.kth.se/~pawsa/balsa/${A}"
+HOMEPAGE="http://www.balsa.net"
+
+DEPEND=">=dev-libs/glib-1.2.10
+ >=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/imlib-1.9.10-r1
+ >=gnome-base/gnome-core-1.4.0.4-r1
+ >=gnome-base/gnome-print-0.30
+ >=gnome-base/ORBit-0.5.10-r1
+ >=media-libs/gdk-pixbuf-0.13.0
+ >=app-text/pspell-0.11.2
+ >=net-libs/libesmtp-0.8.6
+ >=dev-libs/libpcre-3.4
+ gtkhtml? ( >=gnome-extra/gtkhtml-0.16.1 )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+
+ if [ "`use ssl`" ] ; then
+ myconf="$myconf --with-ssl"
+ fi
+
+ if [ "`use gtkhtml`" ] ; then
+ myconf="$myconf --with-gtkhtml"
+ fi
+
+ libmutt/configure --prefix=/usr --host=${CHOST} --with-mailpath=/var/mail
+ assert "configure libmutt failed"
+ ./configure --prefix=/usr --host=${CHOST} --enable-threads --enable-pcre $myconf
+ assert "configure balsa failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README TODO docs/*
+}
+