summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/activerecord/ChangeLog12
-rw-r--r--dev-ruby/activerecord/activerecord-2.3.5-r1.ebuild44
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index 6504d24389df..502d2b8ecfd9 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/activerecord
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.125 2009/12/20 09:09:53 a3li Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.126 2010/01/02 00:09:23 flameeyes Exp $
+
+*activerecord-2.3.5-r1 (02 Jan 2010)
+
+ 02 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +activerecord-2.3.5-r1.ebuild:
+ Bump to fakegem, replace ruby-postgres dependency with pg instead, drop
+ sqlite USE flag (just for now, maybe). Tests are only executed with
+ sqlite3 USE flag enabled.
20 Dec 2009; Alex Legler <a3li@gentoo.org> -activerecord-2.3.4.ebuild:
Removing vulnerable version
diff --git a/dev-ruby/activerecord/activerecord-2.3.5-r1.ebuild b/dev-ruby/activerecord/activerecord-2.3.5-r1.ebuild
new file mode 100644
index 000000000000..ea18bd9d2c12
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-2.3.5-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-2.3.5-r1.ebuild,v 1.1 2010/01/02 00:09:23 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64"
+IUSE="mysql postgres sqlite3" #sqlite
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+#ruby_add_rdepend sqlite ">=dev-ruby/sqlite-ruby-2.2.2"
+ruby_add_rdepend sqlite3 "dev-ruby/sqlite3-ruby"
+ruby_add_rdepend mysql ">=dev-ruby/mysql-ruby-2.7"
+ruby_add_rdepend postgres "dev-ruby/pg"
+ruby_add_bdepend test ">=dev-ruby/mocha-0.9.5 virtual/ruby-test-unit"
+
+all_ruby_prepare() {
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}
+
+each_ruby_test() {
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+#
+# if use sqlite; then
+# ${RUBY} -S rake test_sqlite || die "sqlite3 tests failed"
+# fi
+}