summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/libXaw/ChangeLog10
-rw-r--r--x11-libs/libXaw/libXaw-1.0.5.ebuild29
2 files changed, 37 insertions, 2 deletions
diff --git a/x11-libs/libXaw/ChangeLog b/x11-libs/libXaw/ChangeLog
index 2874e8241a6e..13c8be5462e6 100644
--- a/x11-libs/libXaw/ChangeLog
+++ b/x11-libs/libXaw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libXaw
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/ChangeLog,v 1.49 2007/12/19 23:44:36 cla Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/ChangeLog,v 1.50 2009/01/13 02:38:44 dberkholz Exp $
+
+*libXaw-1.0.5 (13 Jan 2009)
+
+ 13 Jan 2009; Donnie Berkholz <dberkholz@gentoo.org>; +libXaw-1.0.5.ebuild:
+ Bump. Removes XPrint support entirely (libXaw8). Also drops build-time dep
+ on ed.
19 Dec 2007; Dawid Węgliński <cla@gentoo.org> libXaw-1.0.4.ebuild:
Stable on x86 (bug #202087)
diff --git a/x11-libs/libXaw/libXaw-1.0.5.ebuild b/x11-libs/libXaw/libXaw-1.0.5.ebuild
new file mode 100644
index 000000000000..44d42d374107
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXaw/libXaw-1.0.5.ebuild,v 1.1 2009/01/13 02:38:44 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-proto/xproto"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ # No such function yet
+ # x-modular_pkg_setup
+
+ # (#125465) Broken with Bdirect support
+ filter-flags -Wl,-Bdirect
+ filter-ldflags -Bdirect
+ filter-ldflags -Wl,-Bdirect
+}