summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/audiocompress/audiocompress-1.3.ebuild26
-rw-r--r--media-sound/audiocompress/audiocompress-1.5.ebuild26
-rw-r--r--media-sound/cymbaline/cymbaline-0.9r.ebuild14
-rw-r--r--media-sound/imp3sh/imp3sh-0.2.3.ebuild24
-rw-r--r--media-sound/jack/jack-2.99.9.ebuild10
-rw-r--r--media-sound/lilypond/lilypond-1.5.15.ebuild10
-rw-r--r--media-sound/lilypond/lilypond-1.6.6.ebuild13
-rw-r--r--media-sound/lilypond/lilypond-1.6.9.ebuild13
-rw-r--r--media-sound/mp3asm/mp3asm-0.1.3-r1.ebuild13
-rw-r--r--media-sound/splay/splay-0.9.5.2.ebuild6
-rw-r--r--media-sound/squelch/squelch-1.0.1.ebuild13
11 files changed, 74 insertions, 94 deletions
diff --git a/media-sound/audiocompress/audiocompress-1.3.ebuild b/media-sound/audiocompress/audiocompress-1.3.ebuild
index 2ad69ec2a1d7..a72ee0db4f07 100644
--- a/media-sound/audiocompress/audiocompress-1.3.ebuild
+++ b/media-sound/audiocompress/audiocompress-1.3.ebuild
@@ -1,37 +1,35 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-1.3.ebuild,v 1.3 2003/07/12 20:30:47 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-1.3.ebuild,v 1.4 2003/08/07 04:09:25 vapier Exp $
MY_P="AudioCompress-${PV}"
DESCRIPTION="AudioCompress is (essentially) a very gentle, 1-band dynamic range compressor intended to keep audio output at a consistent volume without introducing any audible artifacts."
-SRC_URI="http://trikuare.cx/code/${MY_P}.tar.gz"
HOMEPAGE="http://trikuare.cx/code/AudioCompress.html"
-IUSE="xmms"
-
-S=${WORKDIR}/${MY_P}
+SRC_URI="http://trikuare.cx/code/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+IUSE="xmms"
DEPEND="xmms? ( media-sound/xmms )"
+S=${WORKDIR}/${MY_P}
+
src_compile() {
if [ -n "`use xmms`" ]; then
- emake || die
+ emake || die
else
- emake AudioCompress
+ emake AudioCompress || die
fi
}
src_install() {
- dodir /usr/bin
- install -m 755 AudioCompress ${D}/usr/bin/ || die
+ dobin AudioCompress || die
if [ -n "`use xmms`" ]; then
- installdir="${D}$(xmms-config --effect-plugin-dir)"
- install -d ${installdir} || die
- install -m 755 libcompress.so ${installdir} || die
+ exeinto "$(xmms-config --effect-plugin-dir)" || die
+ doexe libcompress.so || die
fi
dodoc COPYING ChangeLog README TODO
}
diff --git a/media-sound/audiocompress/audiocompress-1.5.ebuild b/media-sound/audiocompress/audiocompress-1.5.ebuild
index b93ceb43719f..a9b6248f2032 100644
--- a/media-sound/audiocompress/audiocompress-1.5.ebuild
+++ b/media-sound/audiocompress/audiocompress-1.5.ebuild
@@ -1,37 +1,35 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-1.5.ebuild,v 1.1 2003/08/06 10:58:24 jje Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audiocompress/audiocompress-1.5.ebuild,v 1.2 2003/08/07 04:09:25 vapier Exp $
MY_P="AudioCompress-${PV}"
DESCRIPTION="AudioCompress is (essentially) a very gentle, 1-band dynamic range compressor intended to keep audio output at a consistent volume without introducing any audible artifacts."
-SRC_URI="http://trikuare.cx/code/${MY_P}.tar.gz"
HOMEPAGE="http://trikuare.cx/code/AudioCompress.html"
-IUSE="xmms"
-
-S=${WORKDIR}/${MY_P}
+SRC_URI="http://trikuare.cx/code/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
+IUSE="xmms"
DEPEND="xmms? ( media-sound/xmms )"
+S=${WORKDIR}/${MY_P}
+
src_compile() {
if [ -n "`use xmms`" ]; then
- emake || die
+ emake || die
else
- emake AudioCompress
+ emake AudioCompress || die
fi
}
src_install() {
- dodir /usr/bin
- install -m 755 AudioCompress ${D}/usr/bin/ || die
+ dobin AudioCompress || die
if [ -n "`use xmms`" ]; then
- installdir="${D}$(xmms-config --effect-plugin-dir)"
- install -d ${installdir} || die
- install -m 755 libcompress.so ${installdir} || die
+ exeinto "$(xmms-config --effect-plugin-dir)" || die
+ doexe libcompress.so || die
fi
dodoc COPYING ChangeLog README TODO
}
diff --git a/media-sound/cymbaline/cymbaline-0.9r.ebuild b/media-sound/cymbaline/cymbaline-0.9r.ebuild
index 2618c6f68dc9..17048d649ad3 100644
--- a/media-sound/cymbaline/cymbaline-0.9r.ebuild
+++ b/media-sound/cymbaline/cymbaline-0.9r.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/cymbaline/cymbaline-0.9r.ebuild,v 1.2 2003/04/24 13:32:23 phosphan Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/cymbaline/cymbaline-0.9r.ebuild,v 1.3 2003/08/07 04:06:35 vapier Exp $
inherit eutils
DESCRIPTION="Smart Command Line Mp3 Player"
-SRC_URI="http://www.silmarill.org/files/${P}.tar.gz"
HOMEPAGE="http://silmarill.org/cymbaline.htm"
-IUSE="mikmod oggvorbis"
+SRC_URI="http://www.silmarill.org/files/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+IUSE="mikmod oggvorbis"
RESTRICT="nostrip"
DEPEND="dev-lang/python
@@ -32,9 +32,7 @@ src_compile() {
src_install () {
dodir /usr/lib/cymbaline
- exeinto /usr/bin
- newexe cymbaline.py cymbaline
+ newbin cymbaline.py cymbaline
insinto /usr/lib/cymbaline
doins ID3.py mp3.py cycolors.py
}
-
diff --git a/media-sound/imp3sh/imp3sh-0.2.3.ebuild b/media-sound/imp3sh/imp3sh-0.2.3.ebuild
index 261e8ec99112..0b1a7e7f738e 100644
--- a/media-sound/imp3sh/imp3sh-0.2.3.ebuild
+++ b/media-sound/imp3sh/imp3sh-0.2.3.ebuild
@@ -1,33 +1,27 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/imp3sh/imp3sh-0.2.3.ebuild,v 1.3 2003/07/12 20:30:52 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/imp3sh/imp3sh-0.2.3.ebuild,v 1.4 2003/08/07 04:10:45 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="flexible playlist manipulation shell and song player/streamer"
-SRC_URI="http://www.geocities.com/kman_can/${P}.tar.gz"
HOMEPAGE="http://www.geocities.com/kman_can/"
+SRC_URI="http://www.geocities.com/kman_can/${P}.tar.gz"
+
LICENSE="GPL-2"
-KEYWORDS="x86"
SLOT="0"
-
-IUSE=""
+KEYWORDS="x86"
DEPEND="sys-libs/ncurses
- oggvorbis? ( media-libs/libvorbis
- media-libs/libogg
- media-libs/libao )"
+ oggvorbis? ( media-libs/libvorbis
+ media-libs/libogg
+ media-libs/libao )"
RDEPEND=""
-
src_compile() {
-
econf || die
emake || die
-
}
-src_install () {
-
+src_install() {
make DESTDIR=${D} install || die
dodoc README* CHANGES web/README.imp3web web/imp3web.php EXAMPLE.imp3sh EXTERNAL.players
# Some docs are liner notes in the actual .c files. UHG.
diff --git a/media-sound/jack/jack-2.99.9.ebuild b/media-sound/jack/jack-2.99.9.ebuild
index 8df509a2a948..4e7321c4cbdd 100644
--- a/media-sound/jack/jack-2.99.9.ebuild
+++ b/media-sound/jack/jack-2.99.9.ebuild
@@ -1,18 +1,16 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/jack/jack-2.99.9.ebuild,v 1.1 2003/07/27 21:25:29 raker Exp $
-
-IUSE=""
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/jack/jack-2.99.9.ebuild,v 1.2 2003/08/07 04:11:05 vapier Exp $
inherit distutils
DESCRIPTION="A frontend for several cd-rippers and mp3 encoders"
-SRC_URI="http://www.home.unix-ag.org/arne/jack/${P}.tar.gz"
HOMEPAGE="http://www.home.unix-ag.org/arne/jack/"
+SRC_URI="http://www.home.unix-ag.org/arne/jack/${P}.tar.gz"
KEYWORDS="~x86"
-LICENSE="GPL-2"
SLOT="0"
+LICENSE="GPL-2"
DEPEND=">=virtual/python-1.5.2
dev-python/cddb-py
diff --git a/media-sound/lilypond/lilypond-1.5.15.ebuild b/media-sound/lilypond/lilypond-1.5.15.ebuild
index 92c59ab97add..b9b449887f33 100644
--- a/media-sound/lilypond/lilypond-1.5.15.ebuild
+++ b/media-sound/lilypond/lilypond-1.5.15.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-1.5.15.ebuild,v 1.6 2003/02/13 13:15:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-1.5.15.ebuild,v 1.7 2003/08/07 04:06:07 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="GNU Music Typesetter"
-SRC_URI="http://www.lilypond.org/ftp/LilyPond/development/${P}.tar.gz"
HOMEPAGE="http://lilypond.org/"
+SRC_URI="http://www.lilypond.org/ftp/LilyPond/development/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
DEPEND=">=dev-lang/python-2.0-r4
@@ -23,8 +22,7 @@ src_compile() {
emake || die
}
-src_install () {
+src_install() {
make prefix=${D}/usr install || die
-
dodoc AUTHORS* CHANGES DEDICATION NEWS README.txt ROADMAP FAQ* VERSION
}
diff --git a/media-sound/lilypond/lilypond-1.6.6.ebuild b/media-sound/lilypond/lilypond-1.6.6.ebuild
index 352464b03aec..6759101b7b4a 100644
--- a/media-sound/lilypond/lilypond-1.6.6.ebuild
+++ b/media-sound/lilypond/lilypond-1.6.6.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-1.6.6.ebuild,v 1.6 2003/03/11 21:11:46 seemant Exp $
-
-IUSE="doc"
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-1.6.6.ebuild,v 1.7 2003/08/07 04:06:07 vapier Exp $
inherit gcc
MY_PV="v$(echo ${PV} | cut -d. -f1,2)"
DESCRIPTION="GNU Music Typesetter"
-SRC_URI="http://www.lilypond.org/ftp/${MY_PV}/${P}.tar.gz"
HOMEPAGE="http://lilypond.org/"
-SLOT="0"
+SRC_URI="http://www.lilypond.org/ftp/${MY_PV}/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 alpha"
+IUSE="doc"
DEPEND=">=dev-lang/python-2.2.1-r2
>=dev-lang/perl-5.6.1-r6
@@ -24,7 +24,6 @@ DEPEND=">=dev-lang/python-2.2.1-r2
doc? ( >=app-text/mftrace-1.0.8
>=app-text/ghostscript-7.05.5
>=media-libs/netpbm-9.12-r2 )"
-
RDEPEND=">=dev-util/guile-1.4-r3
>=app-text/ghostscript-7.05.5
>=app-text/tetex-1.0.7-r10
diff --git a/media-sound/lilypond/lilypond-1.6.9.ebuild b/media-sound/lilypond/lilypond-1.6.9.ebuild
index 1c46208b381e..6acf00023f12 100644
--- a/media-sound/lilypond/lilypond-1.6.9.ebuild
+++ b/media-sound/lilypond/lilypond-1.6.9.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-1.6.9.ebuild,v 1.2 2003/05/27 09:06:31 jje Exp $
-
-IUSE="doc"
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lilypond/lilypond-1.6.9.ebuild,v 1.3 2003/08/07 04:06:07 vapier Exp $
inherit gcc
MY_PV="v$(echo ${PV} | cut -d. -f1,2)"
DESCRIPTION="GNU Music Typesetter"
-SRC_URI="http://www.lilypond.org/ftp/${MY_PV}/${P}.tar.gz"
HOMEPAGE="http://lilypond.org/"
-SLOT="0"
+SRC_URI="http://www.lilypond.org/ftp/${MY_PV}/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
+IUSE="doc"
DEPEND=">=dev-lang/python-2.2.1-r2
>=dev-lang/perl-5.6.1-r6
@@ -24,7 +24,6 @@ DEPEND=">=dev-lang/python-2.2.1-r2
doc? ( >=app-text/mftrace-1.0.8
>=app-text/ghostscript-7.05.5
>=media-libs/netpbm-9.12-r2 )"
-
RDEPEND=">=dev-util/guile-1.4-r3
>=app-text/ghostscript-7.05.5
>=app-text/tetex-1.0.7-r10
diff --git a/media-sound/mp3asm/mp3asm-0.1.3-r1.ebuild b/media-sound/mp3asm/mp3asm-0.1.3-r1.ebuild
index c60a4bd58840..e50c31b6c825 100644
--- a/media-sound/mp3asm/mp3asm-0.1.3-r1.ebuild
+++ b/media-sound/mp3asm/mp3asm-0.1.3-r1.ebuild
@@ -1,16 +1,16 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3asm/mp3asm-0.1.3-r1.ebuild,v 1.2 2003/07/12 20:30:54 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3asm/mp3asm-0.1.3-r1.ebuild,v 1.3 2003/08/07 04:10:18 vapier Exp $
+MY_P=${PN}-${PV}-${PR/r/}
DESCRIPTION="A command line tool to clean and edit mp3 files."
HOMEPAGE="http://sourceforge.net/projects/mp3asm/"
-MY_P=${PN}-${PV}-${PR/r/}
SRC_URI="mirror://sourceforge/mp3asm/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-IUSE=""
DEPEND=""
RDEPEND=""
@@ -18,12 +18,11 @@ RDEPEND=""
S=${WORKDIR}/mp3asm-0.1
src_compile() {
- econf
+ econf || die
emake || die
}
src_install() {
- dodoc ${S}/README
- dodoc ${S}/COPYING
- dobin ${S}/src/mp3asm
+ dodoc README
+ dobin src/mp3asm
}
diff --git a/media-sound/splay/splay-0.9.5.2.ebuild b/media-sound/splay/splay-0.9.5.2.ebuild
index 982a0650e3e4..0a12e7580238 100644
--- a/media-sound/splay/splay-0.9.5.2.ebuild
+++ b/media-sound/splay/splay-0.9.5.2.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/splay-0.9.5.2.ebuild,v 1.3 2003/07/12 20:30:59 aliz Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/splay/splay-0.9.5.2.ebuild,v 1.4 2003/08/07 04:06:52 vapier Exp $
DESCRIPTION="splay is an audio player, primarily for the console"
HOMEPAGE="http://splay.sourceforge.net/"
# Note non-standard sourceforge distribution location, so we can't use
# mirror://sourceforge/...
SRC_URI="http://splay.sourceforge.net/tgz/splay-0.9.5.2.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-IUSE=""
DEPEND="virtual/glibc"
diff --git a/media-sound/squelch/squelch-1.0.1.ebuild b/media-sound/squelch/squelch-1.0.1.ebuild
index aeceffd92d5f..4bafcbf65b36 100644
--- a/media-sound/squelch/squelch-1.0.1.ebuild
+++ b/media-sound/squelch/squelch-1.0.1.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/squelch/squelch-1.0.1.ebuild,v 1.3 2003/03/22 13:49:41 jje Exp $
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/squelch/squelch-1.0.1.ebuild,v 1.4 2003/08/07 04:07:11 vapier Exp $
+
inherit kde-functions
-S=${WORKDIR}/${P}
+
DESCRIPTION="qt-based Ogg Vorbis player"
-SRC_URI="http://rikkus.info/arch/${P}.tar.gz"
HOMEPAGE="http://rikkus.info/squelch.html"
+SRC_URI="http://rikkus.info/arch/${P}.tar.gz"
-SLOT="0"
LICENSE="MIT"
+SLOT="0"
KEYWORDS="x86"
DEPEND="media-libs/libvorbis
media-libs/libao"
-
need-qt 3
src_compile() {
@@ -25,4 +25,3 @@ src_install() {
dobin src/squelch
dodoc AUTHORS COPYING INSTALL README THANKS
}
-