summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-office/lyx/ChangeLog11
-rw-r--r--app-office/lyx/files/digest-lyx-1.3.21
-rw-r--r--app-office/lyx/files/lyx-1.3.2-configure.diff11
-rw-r--r--app-office/lyx/lyx-1.3.2.ebuild86
4 files changed, 108 insertions, 1 deletions
diff --git a/app-office/lyx/ChangeLog b/app-office/lyx/ChangeLog
index e3ebb51b9afe..698bbf7a67fe 100644
--- a/app-office/lyx/ChangeLog
+++ b/app-office/lyx/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-office/lyx
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.24 2003/04/23 00:34:15 vladimir Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.25 2003/05/13 02:28:56 caleb Exp $
+
+*lyx-1.3.2 (12 May 2003)
+
+ 12 May 2003: Caleb Tennis <caleb@gentoo.org> lyx-1.3.2.ebuild:
+ Version bump, does not need patches from previous version as they have
+ been merged into the upstream package (#20708 by Rob Holland).
+ Also incorporate a small patch to fix sandbox violations (#15766), and
+ hopefully some font problems (#15629)
+
07 Apr 2003; Dan Armak <danarmak@gentoo.org> lyx-1.3.1.ebuild:
Fetch the .tar.bz2 not the .tar.gz, as it is considerably smaller. Closes
diff --git a/app-office/lyx/files/digest-lyx-1.3.2 b/app-office/lyx/files/digest-lyx-1.3.2
new file mode 100644
index 000000000000..a0327ef09b31
--- /dev/null
+++ b/app-office/lyx/files/digest-lyx-1.3.2
@@ -0,0 +1 @@
+MD5 e33cf84f7c5be4ab9bbcc6ea587d4fdc lyx-1.3.2.tar.bz2 5469070
diff --git a/app-office/lyx/files/lyx-1.3.2-configure.diff b/app-office/lyx/files/lyx-1.3.2-configure.diff
new file mode 100644
index 000000000000..013cf2c21924
--- /dev/null
+++ b/app-office/lyx/files/lyx-1.3.2-configure.diff
@@ -0,0 +1,11 @@
+--- lib/configure 2003-05-12 20:59:38.000000000 +0000
++++ lib/configure 2003-05-12 20:59:57.000000000 +0000
+@@ -1134,7 +1134,7 @@
+ echo "$ac_t""default values"
+ else
+ echo "$ac_t""auto"
+- rm -f wrap_chkconfig.ltx chkconfig.vars chkconfig.classes chklayouts.tex
++ rm -f wrap_chkconfig.ltx -no-mktex=tfm chkconfig.vars chkconfig.classes chklayouts.tex
+ cat >wrap_chkconfig.ltx <<EOF
+ \\newcommand\\srcdir{${srcdir}}
+ ${linuxdoc_cmd}
diff --git a/app-office/lyx/lyx-1.3.2.ebuild b/app-office/lyx/lyx-1.3.2.ebuild
new file mode 100644
index 000000000000..7bd4c200e482
--- /dev/null
+++ b/app-office/lyx/lyx-1.3.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.3.2.ebuild,v 1.1 2003/05/13 02:28:56 caleb Exp $
+
+DESCRIPTION="WYSIWYM frontend for LaTeX"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2"
+HOMEPAGE="http://www.lyx.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha"
+IUSE="nls cups qt"
+
+DEPEND="virtual/x11
+ app-text/tetex
+ >=dev-lang/perl-5
+ nls? ( sys-devel/gettext )
+ app-text/aiksaurus
+ qt? ( >=x11-libs/qt-3 ) !qt? ( =x11-libs/xforms-1* )"
+RDEPEND="${DEPEND}
+ app-text/ghostscript
+ app-text/xpdf
+ virtual/aspell-dict
+ app-text/gv
+ app-text/latex2html
+ media-gfx/imagemagick
+ cups? ( virtual/lpr )
+ app-text/rcs
+ dev-util/cvs
+ app-text/sgmltools-lite
+ app-text/noweb
+ app-text/chktex"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < $FILESDIR/$P-configure.diff
+}
+
+src_compile() {
+ use nls || myconf="${myconf} --disable-nls"
+ if [ -n "`use qt`" ]; then
+ inherit kde-functions
+ set-qtdir 3
+ myconf="$myconf --with-frontend=qt --with-qt-dir=${QTDIR}"
+ else
+ myconf="$myconf --with-frontend=xforms"
+ fi
+ [ -n "$DEBUG" ] && myconf="$myconf --enable-debug" || myconf="$myconf --disable-debug"
+
+ export WANT_AUTOCONF_2_5=1
+
+ flags="${CFLAGS}"
+ unset CFLAGS
+ unset CXXFLAGS
+ econf ${myconf} --enable-optimization="$flags"
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ einstall
+ dodoc README* UPGRADING INSTALL* ChangeLog NEWS COPYING ANNOUNCE ABOUT-NLS
+}
+
+pkg_postinst() {
+
+ if [ -n "`use qt`" ]; then
+ einfo "WARNING: the QT gui, together with xft2+fontconfig (which you"
+ einfo "almost certainly have), suffer from one infamous bug that causes"
+ einfo "the matheditor not to display any special characters (the ones from"
+ einfo "the Computer Modern font family). Generated documents (.dvi, .ps...)"
+ einfo "are ok, since tex has right fonts from the bluesky package."
+ einfo "A proper solution is being worked on. Meanwhile you can install the"
+ einfo "BaKoMa fonts package; however they are not licensed for redistribution"
+ einfo "(not even embedded inside generated documents) and cannot be used in"
+ einfo "commercial environments (without a special agreement from the author)."
+ einfo "If that suits you, you can get them on CTAN or at ftp.lyx.org as"
+ einfo "latex-ttf-fonts-0.1.tar.gz. I am working on an alternative, free"
+ einfo "fonts package derived from bluesky (see the recent threads on the"
+ einfo "lyx-devel mailing list about this if you want to know more)."
+ fi
+
+}
+