summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-sound/tunapie/ChangeLog7
-rw-r--r--media-sound/tunapie/tunapie-2.1.17.ebuild12
2 files changed, 14 insertions, 5 deletions
diff --git a/media-sound/tunapie/ChangeLog b/media-sound/tunapie/ChangeLog
index 37b73f501402..ffff9e6c6e2b 100644
--- a/media-sound/tunapie/ChangeLog
+++ b/media-sound/tunapie/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/tunapie
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tunapie/ChangeLog,v 1.8 2009/04/30 09:58:26 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tunapie/ChangeLog,v 1.9 2011/07/29 13:37:22 neurogeek Exp $
+
+ 29 Jul 2011; Jesus Rivero <neurogeek@gentoo.org> tunapie-2.1.17.ebuild:
+ Python related improvements wrt bug #373637
*tunapie-2.1.17 (30 Apr 2009)
diff --git a/media-sound/tunapie/tunapie-2.1.17.ebuild b/media-sound/tunapie/tunapie-2.1.17.ebuild
index 84c0bf3e04f0..89cb3d24e408 100644
--- a/media-sound/tunapie/tunapie-2.1.17.ebuild
+++ b/media-sound/tunapie/tunapie-2.1.17.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tunapie/tunapie-2.1.17.ebuild,v 1.1 2009/04/30 09:58:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tunapie/tunapie-2.1.17.ebuild,v 1.2 2011/07/29 13:37:22 neurogeek Exp $
-EAPI=2
+EAPI=3
+PYTHON_DEPEND="2"
inherit eutils multilib python
DESCRIPTION="Directory browser for Radio and TV streams"
@@ -17,6 +18,11 @@ IUSE="offensive"
RDEPEND=">=dev-python/wxpython-2.6"
DEPEND=""
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
sed -i -e "s:/usr/local/share:/usr/$(get_libdir):" ${PN} \
|| die "sed failed"