summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/cryptohash/ChangeLog9
-rw-r--r--dev-haskell/cryptohash/cryptohash-0.9.1.ebuild39
-rw-r--r--dev-haskell/cryptohash/metadata.xml17
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-haskell/cryptohash/ChangeLog b/dev-haskell/cryptohash/ChangeLog
new file mode 100644
index 000000000000..5ef00e49357d
--- /dev/null
+++ b/dev-haskell/cryptohash/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/cryptohash
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cryptohash/ChangeLog,v 1.1 2013/08/25 07:01:28 qnikst Exp $
+
+*cryptohash-0.9.1 (25 Aug 2013)
+
+ 25 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +cryptohash-0.9.1.ebuild,
+ +metadata.xml:
+ dec-haskell/cryptohash
diff --git a/dev-haskell/cryptohash/cryptohash-0.9.1.ebuild b/dev-haskell/cryptohash/cryptohash-0.9.1.ebuild
new file mode 100644
index 000000000000..d62099197562
--- /dev/null
+++ b/dev-haskell/cryptohash/cryptohash-0.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cryptohash/cryptohash-0.9.1.ebuild,v 1.1 2013/08/25 07:01:28 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="collection of crypto hashes, fast, pure and practical"
+HOMEPAGE="http://github.com/vincenthz/hs-cryptohash"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cryptoapi"
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ cryptoapi? ( >=dev-haskell/cereal-0.2:=[profile?]
+ >=dev-haskell/crypto-api-0.5:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9
+ )"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag cryptoapi cryptoapi)
+}
diff --git a/dev-haskell/cryptohash/metadata.xml b/dev-haskell/cryptohash/metadata.xml
new file mode 100644
index 000000000000..58fd22b1d637
--- /dev/null
+++ b/dev-haskell/cryptohash/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A collection of crypto hashes, with a practical incremental and one-pass, pure APIs,
+ with performance close to the fastest implementations available in others languages.
+
+ The implementations are made in C with a haskell FFI wrapper that hide the C implementation.
+ </longdescription>
+ <use>
+ <flag name="cryptoapi">Defines crypto-api instances</flag>
+ </use>
+</pkgmetadata>