summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/emotion/ChangeLog8
-rw-r--r--media-libs/emotion/emotion-1.7.3.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/media-libs/emotion/ChangeLog b/media-libs/emotion/ChangeLog
index 61fd914df664..09ca0d182c60 100644
--- a/media-libs/emotion/ChangeLog
+++ b/media-libs/emotion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/emotion
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/emotion/ChangeLog,v 1.5 2012/11/18 18:39:41 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/emotion/ChangeLog,v 1.6 2012/12/08 14:17:41 tommy Exp $
+
+*emotion-1.7.3 (08 Dec 2012)
+
+ 08 Dec 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +emotion-1.7.3.ebuild:
+ Version bump
*emotion-1.7.1 (18 Nov 2012)
diff --git a/media-libs/emotion/emotion-1.7.3.ebuild b/media-libs/emotion/emotion-1.7.3.ebuild
new file mode 100644
index 000000000000..69e8af9ccce7
--- /dev/null
+++ b/media-libs/emotion/emotion-1.7.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/emotion/emotion-1.7.3.ebuild,v 1.1 2012/12/08 14:17:41 tommy Exp $
+
+inherit enlightenment
+
+DESCRIPTION="video libraries for e17"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer static-libs xine"
+
+DEPEND=">=media-libs/evas-1.7.0
+ >=media-libs/edje-1.7.0
+ >=dev-libs/ecore-1.7.0
+ >=dev-libs/eeze-1.7.0
+ xine? ( >=media-libs/xine-lib-1.1.1 )
+ !gstreamer? ( !xine? ( >=media-libs/xine-lib-1.1.1 ) )
+ gstreamer? (
+ =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-good-0.10*
+ =media-plugins/gst-plugins-ffmpeg-0.10*
+ )"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ if ! use xine && ! use gstreamer ; then
+ export MY_ECONF="--enable-xine --disable-gstreamer"
+ else
+ export MY_ECONF="
+ $(use_enable xine) \
+ $(use_enable gstreamer) \
+ "
+ fi
+
+ if use gstreamer ; then
+ addpredict "/root/.gconfd"
+ addpredict "/root/.gconf"
+ fi
+
+ enlightenment_src_compile
+}