summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/grub/ChangeLog5
-rw-r--r--sys-boot/grub/grub-0.97-r10.ebuild7
2 files changed, 8 insertions, 4 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 21b7610565ba..758b0a0bd09b 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.144 2010/09/02 21:18:09 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.145 2010/09/02 21:19:37 robbat2 Exp $
+
+ 02 Sep 2010; Robin H. Johnson <robbat2@gentoo.org> grub-0.97-r10.ebuild:
+ Fix RDEPEND.
02 Sep 2010; Robin H. Johnson <robbat2@gentoo.org> grub-0.97-r10.ebuild:
Bug #330745: Grub needs executable stack. No version bump yet, new revbump
diff --git a/sys-boot/grub/grub-0.97-r10.ebuild b/sys-boot/grub/grub-0.97-r10.ebuild
index b07369ca9aea..b79a43c6d711 100644
--- a/sys-boot/grub/grub-0.97-r10.ebuild
+++ b/sys-boot/grub/grub-0.97-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r10.ebuild,v 1.5 2010/09/02 21:18:09 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.97-r10.ebuild,v 1.6 2010/09/02 21:19:37 robbat2 Exp $
# XXX: we need to review menu.lst vs grub.conf handling. We've been converting
# all systems to grub.conf (and symlinking menu.lst to grub.conf), but
@@ -22,10 +22,11 @@ SLOT="0"
KEYWORDS="amd64 x86 ~x86-fbsd"
IUSE="custom-cflags ncurses netboot static"
-DEPEND="ncurses? (
+RDEPEND="ncurses? (
>=sys-libs/ncurses-5.2-r5
amd64? ( app-emulation/emul-linux-x86-baselibs )
)"
+DEPEND="${RDEPEND}"
PROVIDE="virtual/bootloader"
pkg_setup() {
@@ -157,7 +158,7 @@ src_install() {
exeinto /usr/lib/grub/${CHOST}
doexe nbgrub pxegrub stage2/stage2.netboot || die "netboot install"
fi
-
+
# bug 330745
pax-mark -m "${D}"/sbin/grub