summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ec2-ami-tools/ec2-ami-tools-1.3.49953.ebuild')
-rw-r--r--app-admin/ec2-ami-tools/ec2-ami-tools-1.3.49953.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-admin/ec2-ami-tools/ec2-ami-tools-1.3.49953.ebuild b/app-admin/ec2-ami-tools/ec2-ami-tools-1.3.49953.ebuild
new file mode 100644
index 000000000000..cc17ec000d76
--- /dev/null
+++ b/app-admin/ec2-ami-tools/ec2-ami-tools-1.3.49953.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ec2-ami-tools/ec2-ami-tools-1.3.49953.ebuild,v 1.1 2010/06/03 12:46:06 flameeyes Exp $
+
+EAPI=2
+
+inherit versionator
+
+EC2_VERSION=$(get_version_component_range 1-2)
+EC2_PATCHLEVEL=$(get_version_component_range 3)
+
+DESCRIPTION="These command-line tools serve as the client interface to the Amazon EC2 web service."
+HOMEPAGE="http://developer.amazonwebservices.com/connect/entry.jspa?externalID=368&categoryID=88"
+SRC_URI="http://s3.amazonaws.com/ec2-downloads/${PN}-${EC2_VERSION}-${EC2_PATCHLEVEL}.zip"
+
+S=${WORKDIR}/${PN}-${EC2_VERSION}-${EC2_PATCHLEVEL}
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/ruby:1.8[ssl]
+ net-misc/rsync
+ net-misc/curl"
+
+src_prepare() {
+ find . -name '*.cmd' -delete || die
+
+ # simplify the scripts to always run ruby18, since that seems to
+ # be what upstream has been using, and we support alternative
+ # implementations as well.
+ sed -i -e '$s:^ruby:exec ruby18:' bin/* || die
+}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r lib bin etc || die
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+EC2_AMITOOL_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+}