summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/arj/arj-3.10.22.ebuild')
-rw-r--r--app-arch/arj/arj-3.10.22.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/app-arch/arj/arj-3.10.22.ebuild b/app-arch/arj/arj-3.10.22.ebuild
new file mode 100644
index 000000000000..a09ff6513ed7
--- /dev/null
+++ b/app-arch/arj/arj-3.10.22.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/arj-3.10.22.ebuild,v 1.1 2005/11/11 23:54:36 carlo Exp $
+
+inherit gnuconfig eutils toolchain-funcs
+
+DESCRIPTION="Utility for opening arj archives"
+HOMEPAGE="http://arj.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arj/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+IUSE=""
+RESTRICT="nostrip"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/001_arches_align.patch"
+ epatch "${FILESDIR}/002_no_remove_static_const.patch"
+}
+
+src_compile() {
+ if [ -x /usr/sbin/gcc-config ]
+ then
+ # Do we have a gcc that use the new layout and gcc-config ?
+ if /usr/sbin/gcc-config --get-current-profile &> /dev/null
+ then
+ export GCC_PROFILE="$(/usr/sbin/gcc-config --get-current-profile)"
+
+ # Just recheck gcc version ...
+ if [ "$(gcc-version)" != "3.2" ] && [ "$(gcc-version)" != "3.3" ]
+ then
+ # See if we can get a gcc profile we know is proper ...
+ if /usr/sbin/gcc-config --get-bin-path ${CHOST}-3.3.4 &> /dev/null
+ then
+ export PATH="$(/usr/sbin/gcc-config --get-bin-path ${CHOST}-3.3.4):${PATH}"
+ export GCC_PROFILE="${CHOST}-3.3.4"
+ else
+ eerror "This build needs gcc-3.2 or gcc-3.3!"
+ eerror
+ eerror "Use gcc-config to change your gcc profile:"
+ eerror
+ eerror " # gcc-config $CHOST-3.3.4"
+ eerror
+ eerror "or whatever gcc version is relevant."
+ die
+ fi
+ fi
+ fi
+ fi
+
+ gnuconfig_update
+
+ cd ${S}/gnu
+ autoconf
+ econf || die
+
+ cd ${S}
+ make prepare || die "make prepare failed"
+ make package || die "make package failed"
+}
+
+src_install() {
+ cd ${S}/linux-gnu/en/rs/u
+ dobin bin/* || die
+ dodoc doc/arj/* ${S}/ChangeLog
+}