summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/bzip2/files')
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.2-NULL-ptr-check.patch27
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.2-bzgrep.patch20
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.2-chmod.patch98
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.3-makefile-CFLAGS.patch16
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.3-makefile-LDFLAGS.patch13
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.3-saneso.patch9
-rw-r--r--app-arch/bzip2/files/digest-bzip2-1.0.3-r63
7 files changed, 0 insertions, 186 deletions
diff --git a/app-arch/bzip2/files/bzip2-1.0.2-NULL-ptr-check.patch b/app-arch/bzip2/files/bzip2-1.0.2-NULL-ptr-check.patch
deleted file mode 100644
index e35080f86db8..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.2-NULL-ptr-check.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Mihai Limbasan writes:
-BZ2_bzclose fails to perform a NULL pointer check before actually
-using the passed BZFILE * argument. The NULL check *is* performed but
-only after the argument is used for the first time, resulting in a
-potential NULL pointer dereference.
-
-http://bugs.gentoo.org/show_bug.cgi?id=75305
-
-Sent upstream but no feedback thus far :(
-diff -Naur bzip2-1.0.2-orig/bzlib.c bzip2-1.0.2/bzlib.c
---- bzip2-1.0.2-orig/bzlib.c 2002-01-05 02:48:41.000000000 +0200
-+++ bzip2-1.0.2/bzlib.c 2004-12-22 15:12:52.824593032 +0200
-@@ -1536,9 +1536,12 @@
- void BZ_API(BZ2_bzclose) (BZFILE* b)
- {
- int bzerr;
-- FILE *fp = ((bzFile *)b)->handle;
--
-+ FILE *fp;
-+
- if (b==NULL) {return;}
-+
-+ fp = ((bzFile *)b)->handle;
-+
- if(((bzFile*)b)->writing){
- BZ2_bzWriteClose(&bzerr,b,0,NULL,NULL);
- if(bzerr != BZ_OK){
diff --git a/app-arch/bzip2/files/bzip2-1.0.2-bzgrep.patch b/app-arch/bzip2/files/bzip2-1.0.2-bzgrep.patch
deleted file mode 100644
index bec6a66af761..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.2-bzgrep.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Ripped from Fedora
-
-* Fri Nov 25 2005 Ivana Varekova <varekova@redhat.com> 1.0.3-2
-- fix bug 174172 - CAN-2005-0758 bzgrep has security issue in sed usage
-
---- bzip2-1.0.2/bzgrep.flaw 2005-06-16 08:51:21.000000000 -0400
-+++ bzip2-1.0.2/bzgrep 2005-06-16 08:55:20.000000000 -0400
-@@ -63,7 +63,11 @@
- bzip2 -cdfq "$i" | $grep $opt "$pat"
- r=$?
- else
-- bzip2 -cdfq "$i" | $grep $opt "$pat" | sed "s|^|${i}:|"
-+ j=${i//\\/\\\\}
-+ j=${j//|/\\|}
-+ j=${j//&/\\&}
-+ j=`printf "%s" "$j" | tr '\n' ' '`
-+ bzip2 -cdfq "$i" | $grep $opt "$pat" | sed "s|^|${j}:|"
- r=$?
- fi
- test "$r" -ne 0 && res="$r"
diff --git a/app-arch/bzip2/files/bzip2-1.0.2-chmod.patch b/app-arch/bzip2/files/bzip2-1.0.2-chmod.patch
deleted file mode 100644
index a97a2b486294..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.2-chmod.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-Ripped from Fedora for CAN-2005-0953
-
-Fixes race condition in setting permissions.
-
-http://bugzilla.redhat.com/bugzilla/155742
-
---- bzip2-1.0.2/bzip2.c
-+++ bzip2-1.0.2/bzip2.c
-@@ -312,6 +312,7 @@
-
- static void copyFileName ( Char*, Char* );
- static void* myMalloc ( Int32 );
-+static int applySavedFileAttrToOutputFile ( int fd );
-
-
-
-@@ -457,6 +458,10 @@
- ret = fflush ( zStream );
- if (ret == EOF) goto errhandler_io;
- if (zStream != stdout) {
-+ int fd = fileno ( zStream );
-+ if (fd < 0) goto errhandler_io;
-+ ret = applySavedFileAttrToOutputFile ( fd );
-+ if (ret != 0) goto errhandler_io;
- ret = fclose ( zStream );
- outputHandleJustInCase = NULL;
- if (ret == EOF) goto errhandler_io;
-@@ -567,6 +572,12 @@
-
- closeok:
- if (ferror(zStream)) goto errhandler_io;
-+ if ( stream != stdout) {
-+ int fd = fileno ( stream );
-+ if (fd < 0) goto errhandler_io;
-+ ret = applySavedFileAttrToOutputFile ( fd );
-+ if (ret != 0) goto errhandler_io;
-+ }
- ret = fclose ( zStream );
- if (ret == EOF) goto errhandler_io;
-
-@@ -1125,7 +1136,7 @@
-
-
- static
--void applySavedMetaInfoToOutputFile ( Char *dstName )
-+void applySavedTimeInfoToOutputFile ( Char *dstName )
- {
- # if BZ_UNIX
- IntNative retVal;
-@@ -1134,16 +1145,26 @@
- uTimBuf.actime = fileMetaInfo.st_atime;
- uTimBuf.modtime = fileMetaInfo.st_mtime;
-
-- retVal = chmod ( dstName, fileMetaInfo.st_mode );
-- ERROR_IF_NOT_ZERO ( retVal );
--
- retVal = utime ( dstName, &uTimBuf );
- ERROR_IF_NOT_ZERO ( retVal );
-+# endif
-+}
-+
-+static
-+int applySavedFileAttrToOutputFile ( int fd )
-+{
-+# if BZ_UNIX
-+ IntNative retVal;
-+
-+ retVal = fchmod ( fd, fileMetaInfo.st_mode );
-+ if (retVal != 0)
-+ return retVal;
-
-- retVal = chown ( dstName, fileMetaInfo.st_uid, fileMetaInfo.st_gid );
-+ (void) fchown ( fd, fileMetaInfo.st_uid, fileMetaInfo.st_gid );
- /* chown() will in many cases return with EPERM, which can
- be safely ignored.
- */
-+ return 0;
- # endif
- }
-
-@@ -1366,7 +1387,7 @@
-
- /*--- If there was an I/O error, we won't get here. ---*/
- if ( srcMode == SM_F2F ) {
-- applySavedMetaInfoToOutputFile ( outName );
-+ applySavedTimeInfoToOutputFile ( outName );
- deleteOutputOnInterrupt = False;
- if ( !keepInputFiles ) {
- IntNative retVal = remove ( inName );
-@@ -1544,7 +1565,7 @@
- /*--- If there was an I/O error, we won't get here. ---*/
- if ( magicNumberOK ) {
- if ( srcMode == SM_F2F ) {
-- applySavedMetaInfoToOutputFile ( outName );
-+ applySavedTimeInfoToOutputFile ( outName );
- deleteOutputOnInterrupt = False;
- if ( !keepInputFiles ) {
- IntNative retVal = remove ( inName );
diff --git a/app-arch/bzip2/files/bzip2-1.0.3-makefile-CFLAGS.patch b/app-arch/bzip2/files/bzip2-1.0.3-makefile-CFLAGS.patch
deleted file mode 100644
index 247c6d95d8b8..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.3-makefile-CFLAGS.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- Makefile
-+++ Makefile
-@@ -10,4 +10,4 @@
- BIGFILES=-D_FILE_OFFSET_BITS=64
--CFLAGS=-Wall -Winline -O -g $(BIGFILES)
-+CFLAGS+=-Wall -Winline $(BIGFILES)
-
- # Where you want it installed when you do 'make install'
---- Makefile-libbz2_so
-+++ Makefile-libbz2_so
-@@ -11,4 +11,4 @@
- BIGFILES=-D_FILE_OFFSET_BITS=64
--CFLAGS=-fpic -fPIC -Wall -Winline -O -g
-+CFLAGS+=-fpic -fPIC -Wall -Winline
-
- OBJS= blocksort.o \
diff --git a/app-arch/bzip2/files/bzip2-1.0.3-makefile-LDFLAGS.patch b/app-arch/bzip2/files/bzip2-1.0.3-makefile-LDFLAGS.patch
deleted file mode 100644
index 54c8fa95eaba..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.3-makefile-LDFLAGS.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- bzip2-1.0.3/Makefile-libbz2_so
-+++ bzip2-1.0.3/Makefile-libbz2_so
-@@ -20,8 +20,8 @@ OBJS= blocksort.o \
- bzlib.o
-
- all: $(OBJS)
-- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.3 $(OBJS)
-- $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.3
-+ $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.3 $(OBJS)
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.3
- rm -f libbz2.so.1.0
- ln -s libbz2.so.1.0.3 libbz2.so.1.0
-
diff --git a/app-arch/bzip2/files/bzip2-1.0.3-saneso.patch b/app-arch/bzip2/files/bzip2-1.0.3-saneso.patch
deleted file mode 100644
index a5d6334e6614..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.3-saneso.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-taken from fedora
-
---- bzip2-1.0.2/Makefile-libbz2_so
-+++ bzip2-1.0.2/Makefile-libbz2_so
-@@ -23,3 +23,3 @@
- all: $(OBJS)
-- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.3 $(OBJS)
-+ $(CC) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.3 $(OBJS)
- $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.2
diff --git a/app-arch/bzip2/files/digest-bzip2-1.0.3-r6 b/app-arch/bzip2/files/digest-bzip2-1.0.3-r6
deleted file mode 100644
index 5ff8c918ad91..000000000000
--- a/app-arch/bzip2/files/digest-bzip2-1.0.3-r6
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 8a716bebecb6e647d2e8a29ea5d8447f bzip2-1.0.3.tar.gz 669075
-RMD160 7ac2a122c254d1fcd54ca8af96a1814e9e245a1a bzip2-1.0.3.tar.gz 669075
-SHA256 4aaa8e7b4ecf03d91c33e8bf92d489533fa6c1f99e825c34058003f18eb68c13 bzip2-1.0.3.tar.gz 669075