summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/makeself')
-rw-r--r--app-arch/makeself/ChangeLog9
-rwxr-xr-xapp-arch/makeself/files/makeself-unpack2
-rw-r--r--app-arch/makeself/makeself-2.1.5-r2.ebuild25
-rw-r--r--app-arch/makeself/makeself-2.2.0-r1.ebuild (renamed from app-arch/makeself/makeself-2.2.0.ebuild)4
4 files changed, 37 insertions, 3 deletions
diff --git a/app-arch/makeself/ChangeLog b/app-arch/makeself/ChangeLog
index 8b1b0b3cf06f..47625974ac03 100644
--- a/app-arch/makeself/ChangeLog
+++ b/app-arch/makeself/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/makeself
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/makeself/ChangeLog,v 1.32 2014/02/18 06:18:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/makeself/ChangeLog,v 1.33 2014/12/21 14:25:39 mgorny Exp $
+
+*makeself-2.2.0-r1 (21 Dec 2014)
+*makeself-2.1.5-r2 (21 Dec 2014)
+
+ 21 Dec 2014; Michał Górny <mgorny@gentoo.org> +makeself-2.1.5-r2.ebuild,
+ +makeself-2.2.0-r1.ebuild, -makeself-2.2.0.ebuild, files/makeself-unpack:
+ Use sys-apps/gentoo-functions, bug #504388.
*makeself-2.2.0 (18 Feb 2014)
diff --git a/app-arch/makeself/files/makeself-unpack b/app-arch/makeself/files/makeself-unpack
index d8f5e17d194c..90b98312c8b9 100755
--- a/app-arch/makeself/files/makeself-unpack
+++ b/app-arch/makeself/files/makeself-unpack
@@ -1,7 +1,7 @@
#!/bin/bash
# Glue to keep unpack_makeself() unchanged
-source /etc/init.d/functions.sh
+source /lib/gentoo/functions.sh
find_unpackable_file() { echo "$@"; }
debug-print() { :; }
emktemp() { mktemp "$@"; }
diff --git a/app-arch/makeself/makeself-2.1.5-r2.ebuild b/app-arch/makeself/makeself-2.1.5-r2.ebuild
new file mode 100644
index 000000000000..6dd500bf94af
--- /dev/null
+++ b/app-arch/makeself/makeself-2.1.5-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/makeself/makeself-2.1.5-r2.ebuild,v 1.1 2014/12/21 14:25:39 mgorny Exp $
+
+inherit unpacker
+
+DESCRIPTION="shell script that generates a self-extractible tar.gz"
+HOMEPAGE="http://www.megastep.org/makeself/"
+SRC_URI="http://www.megastep.org/makeself/${P}.run"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sys-apps/gentoo-functions"
+
+S=${WORKDIR}
+
+src_install() {
+ dobin makeself-header.sh makeself.sh "${FILESDIR}"/makeself-unpack || die
+ dosym makeself.sh /usr/bin/makeself
+ doman makeself.1
+ dodoc README TODO makeself.lsm
+}
diff --git a/app-arch/makeself/makeself-2.2.0.ebuild b/app-arch/makeself/makeself-2.2.0-r1.ebuild
index 5a486145b708..b2b2eb9e6b70 100644
--- a/app-arch/makeself/makeself-2.2.0.ebuild
+++ b/app-arch/makeself/makeself-2.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/makeself/makeself-2.2.0.ebuild,v 1.1 2014/02/18 06:18:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/makeself/makeself-2.2.0-r1.ebuild,v 1.1 2014/12/21 14:25:39 mgorny Exp $
EAPI="4"
@@ -15,6 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE=""
+RDEPEND="sys-apps/gentoo-functions"
+
S="${WORKDIR}/${PN}-release-${PV}"
src_prepare() {