summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/arson/arson-0.9.7-r1.ebuild')
-rw-r--r--app-cdr/arson/arson-0.9.7-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-cdr/arson/arson-0.9.7-r1.ebuild b/app-cdr/arson/arson-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..2d01e5113a1e
--- /dev/null
+++ b/app-cdr/arson/arson-0.9.7-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/arson/arson-0.9.7-r1.ebuild,v 1.1 2002/11/25 05:33:44 agenkin Exp $
+
+DESCRIPTION="A KDE frontend to CD burning and CD ripping tools."
+HOMEPAGE="http://arson.sourceforge.net/"
+LICENSE="GPL-2"
+
+newdepend ">=media-sound/cdparanoia-3.9.8
+ >=media-sound/bladeenc-0.94.2
+ >=app-cdr/cdrtools-1.11.24
+ >=media-sound/normalize-0.7.4
+ oggvorbis? ( media-libs/libvorbis )
+ >=media-sound/lame-3.92
+ >=app-cdr/cdrdao-1.1.5"
+inherit kde-base
+need-kde 3
+
+IUSE="oggvorbis"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+S=${WORKDIR}/${P}-kde3
+SRC_URI="mirror://sourceforge/arson/${P}-kde3.tar.bz2"
+
+use oggvorbis && myconf="$myconf --with-vorbis" || myconf="$myconf --without-vorbis"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 <${FILESDIR}/${P}-write-img-fix.diff || die
+}