summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/jacksum/jacksum-1.5.0.ebuild')
-rw-r--r--app-crypt/jacksum/jacksum-1.5.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/jacksum/jacksum-1.5.0.ebuild b/app-crypt/jacksum/jacksum-1.5.0.ebuild
new file mode 100644
index 000000000000..c4021a851e26
--- /dev/null
+++ b/app-crypt/jacksum/jacksum-1.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/jacksum/jacksum-1.5.0.ebuild,v 1.1 2004/10/25 20:09:39 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Java utility for computing and verifying checksums: CRC*, MD*, SHA*, TIGER"
+HOMEPAGE="http://www.jonelo.de/java/jacksum/"
+SRC_URI="mirror://sourceforge/jacksum/${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="jikes"
+DEPEND=">=virtual/jdk-1.3.1
+ dev-java/ant
+ app-arch/unzip
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jre-1.3.1"
+
+S=${WORKDIR}/${P/j/J}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ unzip -qq ${PN}-src.zip
+ rm ${PN} *.jar
+}
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "compilation error"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ dodoc history.txt readme.txt help/*
+
+ # make exec wrapper
+ echo "#!/bin/sh" > ${PN}
+ echo "cd /usr/share/${PN}" >> ${PN}
+ echo '${JAVA_HOME}'/bin/java -jar lib/${PN}.jar '$*' >> ${PN}
+ dobin ${PN}
+}