summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild')
-rw-r--r--app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild29
1 files changed, 7 insertions, 22 deletions
diff --git a/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild b/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild
index 2d9076fbaf0e..8a9f36b0cfd4 100644
--- a/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild
+++ b/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild,v 1.5 2009/07/24 17:38:20 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-pkcs11/qca-pkcs11-2.0.0_beta2.ebuild,v 1.6 2009/08/19 13:55:19 betelgeuse Exp $
+
+EAPI="2"
inherit eutils qt4
@@ -16,33 +18,17 @@ SLOT="2"
KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
IUSE="debug"
-DEPEND=">=app-crypt/qca-${QCA_VER}
+DEPEND=">=app-crypt/qca-${QCA_VER}[debug?]
>=dev-libs/pkcs11-helper-1.02"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- if use debug && ! built_with_use ">=app-crypt/qca-${QCA_VER}" debug; then
- echo
- eerror "You are trying to compile ${PN} with USE=\"debug\""
- eerror "while qca is built without this flag. It will not work."
- echo
- eerror "Possible solutions to this problem are:"
- eerror "a) install ${PN} without debug USE flag"
- eerror "b) re-emerge qca with debug USE flag"
- echo
- die "can't emerge ${PN} with debug USE flag"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-gcc44.patch
}
-src_compile() {
+src_configure() {
# cannot use econf because of non-standard configure script
./configure \
--qtdir=/usr \
@@ -51,10 +37,9 @@ src_compile() {
|| die "configure failed"
eqmake4 ${PN}.pro
- emake || die "make failed"
}
src_install() {
emake INSTALL_ROOT="${D}" install || die "make install failed"
- dodoc README
+ dodoc README || die
}